Layers panel is too wide, can't be narrowed


#1

The layer panel is this wide:

But I want it to be this wide because that’s all the columns I ever use.

The row of icons across the top appears to prevent it from being narrower. But I don’t use those and don’t care if they’re covered – I’d turn them off if I could.

I would be willing to position the layers panel sticking off the right edge of the screen, so at least the part I’m not using isn’t taking up real estate. But I can’t because whenever Rhino gains focus it repositions the panel completely onscreen. Gosh. If I can’t have it the size I want, can Rhino at least leave it where I put it?

Thanks,
Bathsheba


(Brian James) #2

Hi Bathsheba,

It looks like the pixel width has a minimum width when floating. I’ll see if this can be changed. I did find that you can dock the Layers panel and adjust the sizing to what you want though if that helps.


#3

Dock it, then you can make it as narrow as you want it. For what ever reason the floating panel can’t be any narrower than you have made it but a docked panel can.

6-19-2013 12-33-52 PM.jpg


#4

Thank you for checking into that Brian!

I’d rather not dock it because then I can’t pick the height. But I see it is the best workaround available right now.


#5

I agree with Bathsheba as I’ve come across the same situation, the floating panel minimum width could be half the present setting, or default to the same width as the help panel on a new install of rhino.


#6

This has bothered me from day one. Rhino V4 has no such limit on floating panel width, why was it imposed in V5?


(Brian Gillespie) #7

Thanks, this is now bug http://mcneel.myjetbrains.com/youtrack/issue/RH-19709 (that you can’t see just yet - soon, I hope)