Layer State Manager freezes layer display

After learning of the existence of the Layer State Manager in Rhino for Mac, I started experimenting by creating two complimentary layer displays “flat” and “3D”. To my amazement, not all views were updating when switching between the two states. When I changed the active view, the freeze pattern changed, up to only one view out of four updating! I was not able to establish a pattern as yet. When a view is frozen in the non-active state, it can be manipulated, but the objects are not selectable. The layer panel shows the layer visibility changing as you would expect.

The Rhino file in question: Gastje.3dm (3.6 MB)

I hope I can get my proper file back, either by deleting the layer states in the manager, or by reverting to a previous save.


Software information

Software versions
Rhinoceros version: 5.0.2 (5A865)
IronPython version: 5.1.2015.131
Language: nl (MacOS default)
OS X version: Version 10.9.5 (Build 13F1112)


Third party kernel extensions

Hardware information

Computer hardware
Hardware model: iMac10,1
Processor: Intel Core2 Duo CPU E7600 @ 3.06GHz
Memory: 4 GB
Architecture: Intel 64 bit

Video hardware
Graphics: ATI Radeon HD 4670 256 MB
Memory: 256 MB
Screen size: 2560 x 1440
Displays: iMac (109dpi 1x)

USB devices
Apple Inc.: Built-in iSight
Apple: Internal Memory Card Reader
Apple, Inc: Apple Keyboard
Wacom Co.,Ltd.: CTH-661
Apple Computer, Inc.: IR Receiver
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices

OpenGL information

OpenGL software
OpenGL version: 2.1 ATI-8.24.17
Render version: 2.1
Shading language: 1.20
Maximum texture size: 8192 x 8192
Z-buffer depth: 24 bits
Maximum viewport size: 8192 x 8192

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 2x
Mip map filtering: None
Anisotropic filtering: None

Deleting the layer states did not help, nor did closing and restarting Rhino. I had to revert to an earlier save. Luckily experimenting with layer states was the only change I made to the file, so I did not lose parts of my work. No more Layer State Manager for me!


Thanks, I’ll see if I can reproduce this.

Hmm- works here so far…


I don’t understand what is going on in this file…

The Front and Right views show the 3d model and you can put it in shading mode or wireframe, zoom extends, etc. But you cannot select any of the geometry in the viewports. Thaw doesn’t do anything and all layers are set to unlocked.

The Top and Perspective views show the 2d geometry only. When you hide all curves, dimensions, text, surfaces, and hatches, the 3d model is still visible in Front and Right but zooming extend in perspective echoes ‘Unable to zoom - no objects are visible’.

Are you seeing something else, @pascal?

OK - importing that file into a new Rhino instance makes it behave as one would expect… The 3D geometry is on layers that are off but apparently is ON for just 2 viewports out of 4. Is LayerState supposed to work like that?

@wim are you able to select bits of the 3D geometry? (I should have mentioned that the snapshot and the file I included were taken in the “flat” state, but the front and right views are showing the 3D objects and not the flat objects)


Not when I opened the file in RH5.
When I imported the file in RH5 and turned on the layers, that went fine, yes.
I’ve filed this as a bug since I could not find anything like this reported yet. I can verify that this behavior is not what is expected…Rhino 5 / WIP for Windows do not display this behavior.

I just encountered this in the current Rh5 for Mac. If I turn off a layer using using one of my saved states in LayerStateManager, then the layer’s geometry will no longer appear.

If I do “Select Objects on Layer,” the geometry selects. If I zoom selected, it acts as if nothing’s there. AND: if I draw or create geometry on that layer, as soon as it is creates it disappears! I haven’t figured out how to get my geometry back yet. I’m assuming that I’ll work around this bug for now, because it makes LSM unusable as far as I can tell.

Hrmmm. That does sounds like strange behavior. I’m trying to reproduce this behavior in the latest developer builds and I can’t seem to (perhaps it is fixed, perhaps I don’t full understand the steps to reproduce this yet). So I tried to reproduce this behavior in Rhino for Mac 5.1 and I also cannot. Can you provide very detailed steps to reproduce this?

We have worked on a bug (MR-2612), that might be related to this issue, and the proposed fix will be in the upcoming RhinoWIP update.