Layer Panel Jumps Back to Top when Changing Layer Visibility

Hi there,

Rhino 7 for Windows -
I have a very long list of layers and whenever I change the visibility of a layer it shoots me back up to the top of the panel. To be more specific, it actually only scrolls up to the point where the layer I just changed is now visible at the bottom of the panel.

Just to be clear, it isn’t moving layers around. If you can imagine, if there are a few consecutive layers running down my list that I intend on hiding/showing and I start with hiding the top layer, it would shoot me up and I would have to scroll down until the next layer is visible so I can then hide that one - then repeat and repeat.

Anybody else get this?

Hello - so far, no - my layer panel view stays put when I change visibility - can you please run SystemInfo in Rhino and copy/paste the results?

-Pascal

I’m very jealous.

Here you are…

Rhino 7 SR0 2020-11-9 (Rhino 7, 7.0.20314.03001, Git hash:master @ 9d1a3d02b292e00d3480c301d33f414d91acdcbd)
License type: Evaluation, build 2020-11-09
License details: Cloud Zoo
Expires on: 2021-02-14

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 11-22-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 457.51

Secondary graphics devices.
Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 9-5-2020 (M-D-Y).

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-22-2020
Driver Version: 27.21.14.5751
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Users\devin\AppData\Local\Programs\Enscape\Bin64\Enscape.Rhino7.Plugin.dll “Enscape.Rhino7.Plugin” 0.0.20335.757
C:\ProgramData\McNeel\Rhinoceros\7.0\Plug-ins\Twinmotion Direct Link 2020.2 (e24ee14a-9514-47da-8fe6-f6e61b20160e)\Twinmotion Direct Link 2020.rhp “Twinmotion Direct Link 2020” 1.0.6.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\export_PDF.rhp “PDF Export” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.0.20314.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello - can you please try disabling
“Enscape.Rhino7.Plugin”
and
“Twinmotion Direct Link 2020”

in Options > PlugIns page (only one Rhino open) and then close and restart Rhino?
Does that change anything?

-Pascal

Thanks Pascal!

I knew it was happening before I got Enscape, so I only disabled Twinmotion and it seems to be fine now!

It turns out that isn’t a resolution. It’s doing it again. I have since also disabled the Enscape plugin and it’s still suffering. Help! Thanks again.

Yes getting the same thing here. V7 beta
RM

This is actually becoming very frustrating? Any way I can help work toward a solution here?

@devingrayart, @3dsynergy Does this happen if you start Rhino in safe mode?
@dale - any ideas? So far this does not happen here.

-Pascal

Hey @devingrayart, @3dsynergy,

If I understand correctly:

1.) You launch Rhino 7 for Windows.
2.) You go to the Layers panel and make a bunch of layers - so many that the vertical scroll bar appears.
3.) You grab the scroll bar and drag it to the bottom of the layer list.
4.) You change the visibility of the bottom-most layer by clicking the lightbulb icon.
5.) The layer list scrolls to the top so the layer you just clicked on is no longer visible, unless you re-grab the vertical scroll bar and drag.

Is this what you are seeing?

If so, then I cannot repeat this. It sounds like @pascal isn’t able to repeat this either.

Let me know what I am missing.

Thanks,

– Dale

Hi Dale,

Thanks for checking in. Thanks @pascal for chasing up.

Steps 1-3 are correct. If I click the lightbulb icon of the bottom-most layer then the layer list doesn’t go anywhere - it stays put. If I click the second bottom-most layer, then the scroll bar will scroll up so the bottom-most layer is no longer visible.

It scrolls up to the point where the clicked layer now becomes the bottom-most. Hope that makes sense!

P.S. When I disabled the Twinmotion & Enscape plugins and restarted Rhino7 it temporarily fixed it, but it was only a matter of time until it randomly started happening again. I’m trying to repeat it with another file now and it’s not happening, but maybe it’ll begin out of the blue in a matter of time if I keep the file open…

And, when it happens, can you verify that the two plug-ins are indeed not loaded? I want to make sure about that cause a plug-in can do exactly this sort of thing.

-Pascal

I can confirm the plug-ins are still disabled.
Cheers

See video for demonstration. I can’t replicate it with other files and sadly cannot share this file.

https://drive.google.com/file/d/1kdz8v4KAvO3hJzx18dji4yyoOlc8Y84G/view?usp=sharing

Yep. I see… I cannot make this happen… so it is just the one file? I did not understand that. That would seem to be important but… I can’t think what it might be. Can you please take a screen grab (Alt-PrintScreen) to the clipboard of the entire Rhino window and paste it?

-Pascal

So, this morning when I opened the file it wasn’t happening for some amount of time until it eventually kicked in. Not sure how long it took.

Thanks - nothing astonishing in that screen shot, but I’ll try with a similar docking layout - not that would expect that to have any effect.
(And still the one file, is that correct?)

-Pascal

Thanks Pascal, appreciated.

Yup, still the one file. I might try some other files over the weekend. It seems like it starts off fine when first opened, so I’ll have to trial it over some space of time. I also just tried saving this file as Rhino6 and no troubles there in V6.