Latest WIP and V6.20 won't start after installation

I downloaded rhino_en-us_7.0.19316.14005.exe (11-12-19 6:41pm) and rhino_en-us_6.20.19314.15311.exe (11-10-19 8:08 pm) and did a normal offline installation. When clicking the desktop icon for either one it would show the busy circle for a fraction of a second and then: nothing. Same thing if started from the start menu (Win 7). I deleted the WIP using the windows uninstall program facility and installed the 19295.11595. It started and ran OK.

Any thoughts? Anyone else see this?

I’ve had problems in the past when I installed updates to V6 and V7 WIP at the same time, or one immediately after the other. Solution appears to be to install one, start it and close it, and then install the other.

@brian @pascal
I had a chance to play with this a bit. I tried repair on WIP. I tried uninstall from installer and reinstall on WIP. I tried using a fresh download for both WIP and V6 to install. Nothing worked.

I then proceeded to uninstall both the WIP and V6 and install the last working versions of each and they did, in fact, work. (ie: started and ran OK.)

edit: one thing I did not try, but just now thought about it: I didn’t uninstall BOTH installations before trying to install ONE of them again (per David, above).

I guess I’ll wait until next week’s versions come out and try again.

The symptoms:
Rhino installation is done.
The desktop shortcut is there.
The Rhino installation folder is empty.
Rhino can be found in Windows settings > App for uninstall.
Uninstall and re-install Rhino. Fixed.

RH-38092 is the YT issue I reported about three years ago.
I tried to reproduce this problem, but have never succeeded.