Latest Iris win seems broken


(Willem Derks) #1

Hi,

I downloaded iriswin.rhi from Foodfor rhino, yet I still get an error loading Iris:
image

Is this a known issue?

-Willem


(Luis Fraguada) #2

I believe so. You have RhinoWIP installed correct? I believe this has something to do with RhinoWIP rhiexec taking over how Windows deals with rhi files. Can you try something, can you right click on iriswin.rhi and try to “Open With” and choose the Rhiexec at this location: C:\Program Files\Rhinoceros 5 (64-bit)\System\x64. Let me know what happens.

Thanks.

Edit: I tried to go back and install with both RhiExecs (from Rhino 5 and Rhino WIP) and didn’t get this error, Iris installed fine and exports fine.

You could also try to clean out the Iris folder in C:\Users\username\AppData\Roaming\McNeel\Rhinoceros\5.0\Plug-ins.

If all else fails, you could change the .rhi extension to .zip and extracting contents and you’ll have an rhp to install.


(Will Pearson) #3

Hi @Willem,

Can you send over the install log for Iris? It should be in one of the following directories…

  • %APPDATA%\McNeel\Rhinoceros\5.0\logs\
  • %APPDATA%\McNeel\Rhinoceros\6.0\logs\

I’d like to double check that the RHI installed correctly and which version of rhiexec.exe was used.


(Willem Derks) #4

Hi Will,

It seems iris is now installed correctly in the WIP.

Here are todays logs:
5.0LOGS.zip (3.9 KB)
6.0LOGS.zip (9.9 KB)

HTH
_Willem


(Willem Derks) #5

I did this, and since I had the folder still open for the V6 logs, I saw an item appear there.
So even when explicitly pointing to the RhiExec from V5 it still got to V6 somehow.

When I now open the WIP, I get the error for Iris. Running the iriswip.rhi will get the correct one installed.

I’ll wait for a new intaller, no hurry for now.

good luck fixing it!

_Willem


(Will Pearson) #7

@Willem, after installing iriswin.rhp, if you click on Details, do you see the “plug-in not compiled for this version of Rhino” error?

50

Rhiexec (WIP) treats V5 plug-ins as being compatible because Rhino WIP is capable of checking V5 plug-ins for compatibility on load. I checked the Rhino command line and found that Iris.Win.rhp had failed the compatibility test…

Testing C:\Users\will\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\Iris (1cd9c8f5-c901-426c-8e80-d6a2e2b18bba)\1.0.6379.18184\Iris.Win.rhp (and one other assembly) for compatibility...
-\//---||--\\\-
Compatibility test failed in 3.09s
Unable to load Iris.Win.rhp plug-in: plug-in not compiled for this version of Rhino.

(Willem Derks) #8

YES:

-Willem


(Luis Fraguada) #9

@will has identified the behavior and I’ve changed the installer. The Windows installer is combined which should allow the installer to place the appropriate Iris versions for each version of Rhino for Windows.

Luis


#10

Hi, I have the same problem on my laptop, but a little different. I have the latest download, It wouldn’t install until I used this method. ( “Open With” and choose the Rhiexec at this location: C:\Program Files\Rhinoceros 5 (64-bit)\System\x64) Iris installed in 5 and not 6. But I still cannot install it in 6.I tried a new download but no luck.
On my desktop everything installed no problem from the previous download.


(Will Pearson) #11

@fishtriangles, can you please send me the log for the last time that you tried to install Iris using the default (Rhino WIP) RHI installer? It should be in %APPDATA%\McNeel\Rhinoceros\6.0\logs\.


#12

logs.zip (3.5 KB)


(Will Pearson) #14

@fishtriangles From the log (08/15/2017 08:08:24) Iris is being correctly installed for Rhino WIP, but not for Rhino 5 SR14 (64-bit). This could potentially be a bug in the Rhino Installer Engine. I’ll investigate and get back to you.

Update: Tracking this in RH-40795.


(Dan Belcher) #15

RH-40795 (and RH-40718) should be fixed in the latest WIP.


(Will Pearson) #16

@fishtriangles As Dan mentioned above, these Rhino Installer Engine bugs should be fixed in the Rhino WIP that was released yesterday. If you upgrade and reinstall iriswincommon.rhi, it should install the correct versions for both Rhino WIP and Rhino 5 SR14!


#18

Hi, I tried to install iris again but no dice.

WIP 60.17255.11421.2017-09-12
Version 5 SR14 64-bit (5.14.522.8390, 22-May-17)

Plugin dependencies show \1.0.6379.18184\Iris.win.rhp on both computers I downloaded today but it still won’t install.

I’m getting the Initialization failed message on 5 and 6 on the laptop
On the desktop 5 the message is iris version has expired and 6 gives the Initialization failed message.
Is there anything I can do on my end?

Thanks,
Mike


(Luis Fraguada) #19

Installers have been updated. Let me know if it still fails.


#20

Partial success on both computers. On both computers the version I started first after the install worked but not both versions. Desktop installed on WIP , not on 5. error says Iris out of date download new version it doesn’t change with newer downloads. The install message only said 6 installed.

On the laptop I opened 5 first and Iris installed but not on 6. The message at install said both versions installed, but did not.
I am ok with the way things are now, I just thought you might want to know. Also windows wanted to update at the same time. I tried again after the update but no change.


(Luis Fraguada) #21

Screenshots of these messages would help.


(Will Pearson) #22

And the RHI logs, if possible!


#23

desktop first is from installation, the second is when I started 5. Will
send seperate laptop images