Latest Iris win seems broken


#24

laptop Iris is working on 5 not 6 I started 5 first after the
install. and started 6 first n the desktop that is where Iris is working
on each computer


(Luis Fraguada) #26

Can you please post the logs as you had done before with the instructions from @will?


(Willem Derks) #27

Hi Luis,

It’s working as expected here! For both versions iris installed correct!

Thanks
-Willem


#28

Desktop all logs with todays date from both 5 + 6

iriswin(1) (20170918-123850)desk.zip (12.2 KB)

InstallPackagesForRhino (20170918-124002)_desk.zip (1.94 KB)


#29

Today’s date logs from laptop for 5 and 6

5_logs_laptop.zip (2.11 KB)

6_logs_laptop.zip (22.1 KB)


(Will Pearson) #30

Hi @fishtriangles. Thanks for the logs. I’ve been looking into the laptop situation… It appears that the correct version of the plug-in was installed and registered for Rhino WIP, so we’ll need some more information to figure out why it’s failing to load. I’ve put together some troubleshooting steps below.

First, the easiest option. There was a new Rhino WIP released yesterday. Please give that a try. If it doesn’t magically resolve the issue, then continue below…

Next, please remove all the old version of Iris and try installing again.

Close Rhino, navigate to %APPDATA%\McNeel\Rhinoceros\6.0\Plug-ins and delete the folder named “Iris (1cd9c8f5-c901-426c-8e80-d6a2e2b18bba)”. Then try installing the latest Iris RHI again.

If this doesn’t work, would you mind trying to load the plug-in via drag’n’drop? This will effectively remove the Rhino Installer Engine from the process, helping us to isolate the problem.

  1. Make a copy of the Iris RHI and rename the extension to “.zip”
  2. Unpack the ZIP
  3. Drag Iris.WIP.rhp into the Rhino Viewport

If Iris loads correctly, then I’d like to double check that the RHI is registering the plug-in correctly.

  1. Close Rhino and reinstall the Iris RHI
  2. Open the Windows Registry (type “regedit” into the Windows start menu search box to find it)
  3. Navigate to HKEY_CURRENT_USER\SOFTWARE\McNeel\Rhinoceros\6.0\Plug-ins\1CD9C8F5-C901-426C-8E80-D6A2E2B18BBA, using the tree view on the left
  4. Export the key (right click on the 1CD9C8F5-C901-426C-8E80-D6A2E2B18BBA node in the tree view and choose export, then change the format to text file)

If you can send the .txt export to via direct message (there shouldn’t be any sensitive data, but I’m just being careful) I’ll have a look to make sure that the correct version of the plug-in was registered.


#31

I went through it all,on the laptop. The drag and drop worked. I
restarted 6 and it loaded on its own, with no messages on 5 or 6

I tried it on the desktop in 5 but it still said this version of Iris
has expired…

Thanks,


(Luis Fraguada) #32

@fishtriangles what version of Rhino 5 service release do you have? As stated here, you need at least Rhino 5 sr12. Is the message you are seeing that Iris is out of date, or that you need to update Rhino?


#33

Rhino Plug In Error Iris.Win.Rhp This version of Iris has expired. Please visit…

Version 5 SR14 64-bit
(5.14.522.8390, 22-May-17)


#35

I get the same error that Iris is out of date even though I downloaded it 10 minutes ago.


(Will Pearson) #36

@fishtriangles I just re-read the logs and caught something that I missed before. The version of Rhino WIP on your desktop is over a month old (6.0.17220.11131, August 8, 2017). I’ve already fixed the bug that is preventing Iris from being installed for Rhino 5 (64-bit) SR14. Updating Rhino WIP to the latest build should solve your problems on this machine.


(Will Pearson) #37

Hi @Joseph_Culbert, could you provide some more information? I’d be very interested to see the log from the latest attempt to install Iris. You can find this in %APPDATA%\McNeel\Rhinoceros\5.0\logs (replace “5.0” with “6.0” if you have Rhino WIP installed).


#38

Will,

The first time I installed by dbl clicking the .rhi file. When I opened a new instance of 5.0 I got the error. I read here someone mention drag and drop so I tried that on an open 5.0 and got a message that Iris was sucessfully installed. But when opening a 5.0 instance got the same error as before.  

iriswin (1) (20170920-144549).zip (2.7 KB)


(Will Pearson) #39

Did you drag and drop the RHI file, or the Iris.Win.rhp file that’s inside the RHI? (Note: the RHI is just a renamed ZIP.)


#40

It seems to be working now in V6 fine. I’ll look and see what is in the zip.


(Will Pearson) #41

Glad it’s working in the WIP for you :+1:. If you wouldn’t mind sending over the latest log for Iris in %APPDATA%\McNeel\Rhinoceros\6.0\logs too, I’d be interested in having a look…


#42

Is this what you need?iriswin (1) (20170920-130256).zip (3.3 KB)


(Will Pearson) #43

That’s the one. Thank you. Unfortunately I can’t see a reason for Iris not to load in Rhino 5.

I appreciate your help so far. As I’m sure you can understand, it’s difficult to resolve these issues when we can’t reproduce them on our own machines!

I’m curious to know which version of Iris is registered for Rhino 5. Are you familiar with the Windows registry?


#44

Registry is above my paygrade! Thanks for your help and maybe having Iris working in v6 will encourage me to spend more time there. I might have a look at the registry as you suggest.


(Will Pearson) #45

No worries. Thanks for digging into this with me.