Last Wip V6 install problem


#1

Hi Brian
I have a problem installing last WIP . See teh attached Image.
When I click OK, nothing happens
Vittorio


(Brian James) #2

@brian Can you help here?

Translated message reads:

The feature is located in a network resource not available

Click OK to try again or enter into the box below the path to a folder containing the installation package “rhino.msi”


#3

Hi Brian
Your translation is ok.
Below there imagines where are The file downloaded and the directory where there is not the .msi file


(Brian Gillespie) #4

Ciao Vittorio,

Something got deleted from your computer that the installer was expecting to find.

I have seen this happen when updating from an older version of Windows to Windows 10 - did you do that since the last WIP was installed?

Or, do you have a program that you use to clean up “unnecessary” things from your computer?


#5

Hi Brian
In the attached picture you can see that in directory
C:\ProgramData\PackageCache[…] The Last modify of the .msi file was
made on 11.18.2016 . Obviously when I install the new versionnot update the
file .msi. .What can be done?
Vittorio


(Mikolaj Jarski) #6

Not sure if it is the same problem but the topic matches: I can’t update nor install Rhino WIP.
Installed version is 6.0.17116.6371, 26.04.2017.
Update just terminates at inital stage.
When I download and install rhino_en-us_6.0.17136.10381.exe the following screen appears:

The log file: Rhino_WIP_20170518093415.txt (26.1 KB)


(Mikolaj Jarski) #7

Help please!


(Mikolaj Jarski) #8

@brian - Can you help?


(Brian Gillespie) #9

@mikolaj - sorry I missed this before. Can you please try installing the latest WIP and send the latest log files?


(Mikolaj Jarski) #10

@brian - Sure. I’m getting the same error code.
The log files: Rhino_WIP_20170524223539.txt (27.2 KB)


#12

This has happened to me too. I’m sure I’ve totally mucked things up trying to fix it myself. Its getting stuck trying to remove the old version. I tried to uninstall from Control Panel, but it said there was an error and did I just want to remove Rhino WIP from the list of installed programs, so I said yes. Then I deleted the Rhino WIP folder in Program Files but it still wouldn’t install. Then I tried CCleaner to ‘clean’ the registry but that hasn’t helped neither.

BTW, I hadn’t done anything crazy between this version and the last of Rhino WIP (like run CCleaner or update windows - Creators update hasn’t appeared on this PC yet) so I don’t think I’m to blame. I did install a few Grasshopper plugins though.

Any help?Rhino_WIP_20170525111350.zip (22.4 KB)


#13

I was feeling desperate so I deleted a bunch of registry keys in HKLM\SOFTWARE\CLASSES\Installer\Products that had to do with Rhino 6, and got the latest WIP to install after that. Hopefully I haven’t caused any problems further down the road.


(Mikolaj Jarski) #14

@brian - Can you look into it? From what @gavinmetzler reports, I understand deleting some registry keys should solve it but perhaps you could point out which exactly are safe to be deleted.


(Brian Gillespie) #15

Hi @mikolaj,

The install problem you’re seeing, and the one reported by @gavinmetzler are different. His solution is likely not going to work for you.

What happens if you first remove Rhino WIP from your computer before installing?

Sadly, there’s very little useful information in the log files you sent - please send the next ones. I hope they have something more descriptive.


(Mikolaj Jarski) #16

Rhino_WIP_20170605211840.txt (20.8 KB)


(Brian Gillespie) #17

Again, there’s really nothing here. There’s absolutely no indication about why installation is failing.

I wonder if some part of the installation is being blocked by a virus scanner?


#18

Hey @mikolaj,

I had a look at your log, I think it may be the same problem I had, but I’m no expert!

I think these were the keys I had to delete. Obviously registry editing is dangerous, so backup and/or get help.




(Mikolaj Jarski) #19

@gavinmetzler - many thanks, but it seems Brian was right - it works when I deactivate virus scanner.