Lands Design doesn't show up in Grasshopper


After the last couple of updates, the Lands Design tab in Grasshopper disappeared.
I already tried to reinstall. Any good suggestions on how to make it work?

Best Regards
Mikkel Steenberg

Hi Mikkel,
Close Grasshopper, load Lands Design by running any Lands command (i.e “laPlant”) and then open Grasshopper again. Do you see the Lands components then?

Hi Fransesc,

No unfortunately not.
I can see that it starts up grasshopper, but I still can’t see the tab or search for the components

Hi Mist,
That’s weird. Try it this way: Close Rhino, open Rhino, load Lands Design, and open GH.
If you double click on GH canvas and search for a Lands component (“Plant”), does it show any?
What Rhino and Lands Design version are you running?


I have got exactly the same problem, and I have tried everything, including the method which you suggested. The components don’t appear in the tool bar of Grasshopper and they can’t be searched. Really looking forward to a solution ~


@arch.enlight, @mist if you run any Lands command in Rhino, does it work? in which license mode are you running Lands Design? (run the laLicense command to check it out).

The last version was released before 90 days, so if you have it, it should not be expired yet, which may explain why you don’t see the Lands components in GH. Just in case, try to download and install the current version, and check if the problem persists.

Yes, lands work. The components in Grasshopper is the only thing not showing up
I’m running it in Cloud Mode on the newest version

@mist, Can you check if the file GhLaRhino6.tba is located in the following folder? C:\Program Files\Lands Design (Rhino 6)\Bin
In your case, the components don’t show up either if you search them by double clicking on GH canvas?

I can confirm that the GhLaRhino6.tba file is located at C:\Program Files\Lands Design (Rhino 6)\Bin.
No, they don’t show up.
Could it be a clash with another plugin?

Once Lands is loaded, if you open a 3dm file or if you create a new Rhino document (File > New…), do the Lands components appear in Gh?

Once Lands is loaded, can you see the following plugins in the Grasshopper Preferences dialog (“File > Prefereces…” under the “Solver” tab):

  • TbGh18
  • GhLaRhino6
    Is any of them locked?

What other Gh plugins have you loaded? If you have recently added new plugins, can you lock them and try to load Lands (by closing Rhino and opening it again)? Does it make any difference?

Hi Albert,

No there is no sign of lands inside of Grasshopper.
When I start op Lands I can see that grasshopper is initialized, but it still doesn’t show up in GH.

There is no sign of tbGh18 or ghLaRhino6 in the solver.

I tried both to lock all my loaded plugins, and remove my libraries/Userobjects and reinstall Lands, but I still don’t get Lands i GH.

Ok, it looks like the module is failing to load. Maybe due to some missing dependency. Do you have Flamingo nXt installed? Do you have VisualARQ installed?
What Rhino version do you have?
What Lands Design version? 5.xx.xx?
What Tibidabo version? 18.5?
You can see both Lands and Tibidabo versions in the command line just after Lands is loaded

I don’t have Flamingo.
VisualARQ is installed and showing up fine!
Rhino 6 SR 26 (6.26.20147.6511)
Lands Design 5.3.6356
Tibidabo 18.15


Then, VisualARQ components are shown in gh?

Yes, VisualARQ is showing up

That’s good. Can you check if your GhLaRhino6.tba file, located at “C:\Program Files\Lands Design (Rhino 6)\Bin” has the following properties:
Creation date 10 June 2020
Size 1.835.336 bytes
Unfortunately this file has no version number so we must compare it this way.

Yes, that matches the GhLaRhino6.tba file I have

All looks right. Just to ensure the windows registry is also right, can you launch Rhino using the “Lands Design (Rhino 6)” desktop icon at least once? This launcher does some setup that could help.
Can you see now the Lands components in Gh?

That worked! Thank You :slight_smile:
I had already ran it once, but apparently it needed another go!

Great! :slight_smile:
I guess you ran it long ago for a lower Tibidabo version (18.14 for example). We’ll try to improve that.

1 Like