Karamba 3.0 not loading in Rhino 8

I’ve recently moved from RH7 to RH8, and most of my grasshopper plugins moved across smoothly - apart from Karamba3D. The Karamba commands in Rhino work (i.e. Karamba3DGetLicense) but when I open grasshopper, none of the components are available and no toolbar.

I’ve tried reinstalling and updating using the package manager, but no joy. Any suggestions about what to try next?

(running on Windows 10.0.19045)

Hi, in any case, you can use the installer for Rhino8

Still no improvement using the msi installer from the Karamba website - the package files are installed in the right plugin folders, but Grasshopper in RH8 is still not showing or allowing the components.

At the moment having to switch back to RH7 for Karamba, which is painful in terms of workflow!

You can try to drag and drop the “karamba.gha” file into the gh canvas and see if it appears.

This works for that instance of Grasshopper but does not install it permanently; when I reopen RH8 it is still not present.

It feels like the package manager and the .msi are installing in the wrong location.

Hi @david10, what version of K3D do you use?
When using the latest msi-installer from here make sure to use “Karamba3D_RH8_Core_3_1_40223.msi” for Rhino8 running in .NET7. The other K3D version is for .NET Framework.
– Clemens

Thanks Clemens - now resolved with the latest msi. I was trying to use the version on the Karamba website [ I think] but [3.1.40320-WIP] worked fine once I had removed the old versions.