Just how can one get Rhino vector into Photoshop with transparent background?

In my project I draw a 200mm x 200mm box in Rhino on my laptop, select it, export selected as ai cmyk.
open Pshop CS2
open the ai file, it says width 73.91mm height 43.96mm 200 pixels per inch.
its not even square !

masses of white space off to left.

I need to get my Rhino artwork into photoshop as different layers so need the transparent nature of ai,…
or anything else that will see my curves, solid hatch fills and transparency.

What should I be doing to manage this ?

Why is an ai export failing so badly ?

I then do a test, I try this as a new file on tower with CS6 and get a 200x200 box, so why CS2, yet I had issues a while ago with tower and ai into CS6.

I create a new file on laptop and draw 200x200 and this works !

I copy paste my 200x200 square that failed to a new 3dm file and this also then fails.
Open the copy pasted square onto tower and export as ai, still it fails,
yet a new file with 200 x 200mm square from tower rhino V5 works.

the offending 3dm which is the square from my project pasted to a new file is attached, as is the ai export of it both from laptop then tower.

200x200 copypasted.3dm (23.2 KB)

200x200mm inst file copypaste new file lappy v5 then using tower.zip (917 Bytes)

200x200mm inst file copypaste new file lappy v5.zip (840 Bytes)


Is your square drawn at Rhino’s origin?

In Photoshop, did you try the Crop To: Bounding Box option?

No it was out away from origin, as would be the normal case.

I didnt choose crop bounding box.,. even for the tests now done. In fact the file,open box in CS6 says rasterize eps option and there is no bounding box crop option.

see tests now done.

even those that did work were not at origin.


Either… ExportWithOrigin from Rhino (select bottom left hand corner or your rectangle), or re-save your exported .AI in Illustrator to make the Bounding Box option appear when opening in Photoshop.

I suspect that Rhino doesn’t export a fully-fledged Illustrator file, just something which Illustrator is happy to read.


Illustrator expects things to be on a “page”. Hence it reads the Rhino origin as the bottom left of the page.

Sooooo, IF your square does not have it’s bottom left corner at 0,0 in Rhino, scaling will be quite random in PS.

Couple of ways around this.
1/. Put objects you want to export so that their bounding box is at 0,0
2/. Do a round trip via Corel Draw. Import your AI file into Corel. Then export selected as EPS. Then create PS file that is bigger than the object and Place Embedded. It WILL scale correctly.


does it have to be vector? If you export a screen shot at 1:1 and set it to multiply in photoshop all the white areas will be transparent? I’ve used this to overlay a pen mode view over a rendered view.

I dont own Illustrator or Corel and cant afford them for this purpose. I just wish Rhino exported as eps as that was how I exported from Freehand Vector graphics prog to Photoshop. Worked a treat. Vital was the ability to colour items as cmyk and open as such. There is no cmyk colour palette in Rhino which enables easy altering of all instances of a cmyk colour by alterijg the layer colour and this is the big problem when needing to create a cmyk raster image in photoshop from Rhino.

I guess I will have to save file as name ‘file for export Pshop’, just in case it does an automatic save during the following !..or the PC fails., then resite 0,0 at box lower left, then do the exports. Close then reopen the normal file.

Exporting as eps doesnt have the origin issue.

There would appear to be no way of going from Rhino into Pshop with transparent backgrounds as vector without this workaround then.

I export various parts of the drawing, open each into photoshop and assemble as one psd file these as layers in photoshop. The export box preserves scale for the exported items, they must all be within it.

I need to keep mathematical the relationship between the line weights in source file and their appearance in pshop so screen shots is not something I would be comfortable with.