*Export to .ai fail* Even online converters can't open the file?

Looking for some clarification on this.

I understand Rhino does export to Illustrator (from the export menu).

Yet, when I try to open the .ai file all I get is a blank canvas. Model space is preserved at 1:1 and the 2D set of curves I am trying to export are located at 0,0 (min X, minY).

Is there a trick to getting this to work?

Rhino 5, 64-bit for Windows

Can you post the file in question?
If the curves are invalid (SelBadObjects) they will not export.
Are the curves also at 0 in Z?
I seem to recall that there are problems with large objects - might the curves be larger than the maximum size the Illustrator canvas can support? (I think it’s something less than 6000 mm).


Thanks for your reply Mitch.

As far as I can tell, all points are at z0. The actual model itself is 1100 x 1800 mm.

Here are the Rhino and Illustrator files in question: Archive.zip (89.7 KB)

Well, your Illustrator file looks OK over here opened in CS6 (Windows). The curves are much bigger than the artboard size, but if you zoom out you see them and they look correct. Exporting your .3dm over here produces the same result.


Briefly, Your vector program must have support to read Ai files from version 8

Ha, you’re absolutely right, I just checked on another machine with CS6 (Windows).

Seems Affinity Design (on my mac) doesn’t like the .ai file for some reason & up until a few minutes ago I had assumed it handled .ai files flawlessly.

Thanks, that was an easy fix :slight_smile:

Hmm, something to check might be if exporting as RGB or CMYK makes a difference… --Mitch

Tried CMYK and RGB, same result with Affinity Design.

This worked though: I opened the .ai in CS6, rescaled the artboard, saved it, then opened in Affinity and it was suddenly happy. All curves were present as sublayers.