Jagged edges on planar surfaces and edges? how to fix

Hi guys.

I’m having trouble getting rid of these weird jagged edges that are appearing on some of the polysurfaces in my model. I 'm pretty sure they appeared after i changed the intensity of the environment, as i didnt have any problems with this when creating the shapes themselves. It also seems to only appear on some objects, being the ones that are supposed to be made from straight edges and flat surfaces. I’m really confused on how to work around this. If anyone has any idea please let me know. Thanks :slight_smile:

Hi @awadrop
It’s a little hard to tell for sure without a file, but two things come to mind: Are you, by any chance, far away from the world origin? It could be meshing errors due to floating point limitations. It could also be your render mesh settings? Try setting the render mesh under options>document properties>mesh to smooth and slower.
Last thing to check is duplicate objects, but I don’t think that’s the case.
HTH, Jakob