Jagged Mesh

Hi! I have been trying to make a mesh to 3D print. I have been having all sorts of problems, but especially with my mesh looking jagged and that translating to Slic3r. I have tried adjusting to “smooth and slow,” and I do not believe it is an imaging issue but maybe an actual issue with my mesh? The mesh itself says it is closed and was generated from a closed polysurface. The mesh should be a smooth cylinder tube shape. Any help is appreciated!

Another note: When I do the mesh at a full size scale it is okay (diameter of the tube is 30’) but when I scale down to 1/16" scale for 3D printing, the mesh gets messed up and jagged.

Also, just noticed that I can scale down to 1’ = 1/2" minor deformities are seen. Anything smaller, 1’ = 1/4", etc. and they become more intense. This is really making me feel like this is a render/graphics issue, but the problem persists across softwares and computer…

Have you tried changing the absolute tolerance setting? A tolerance that works at 30’ can cause issues like you are seeing at 1/16" scale. As a general rule of thumb, the absolute tolerance should be set to 1/10th of the smallest model detail. To check or set the Absolute Tolerance go to:
File > Properties > Units > Model and look at the Absolute tolerance entry. Mine is set to 0.01 units and my units is feet so it is 0.01 feet or 0.12" which is much too big for working on a model with 1/16" details. I am working on a 2500’ model so if is fine for me but it would be awful for you. The absolute tolerance is set when you pick the units for a new Rhino workspace. I chose feet and large which gave me 0.01 absolute tolerance. If I chose feet and small it would be 0.001 which could work for your case with the 1/16" model dimensions.


Thank you for replying Terry! Unfortunately that did not work. Attached is a picture with the units set to millimeters and the absolute tolerance set to .001 units. As you can see, the mesh is still jagged. The work around that I have found is to scale it down to a size where the mesh is still intact and then scale it more in Slic3r.

What is your angle tolerance setting?

Is your object very far from the origin? This looks a typical case for that… If so, try moving it closer to the origin and then re-run the Mesh command and check the results.

For 3D printing I would always scale the original object to model size before meshing. Then mesh with settings smaller than your 3D printer resolution. You also want the file in inches (or mm) but not feet.

I always suggest a custom mesh for these purposes, you have much better control. Have a look at this page for detailed mesh setting info.

As your 30’ diameter tube will be 1-7/8" at 1/16"=1 foot scale (If I got that correctly, I hate English units), you might start with a Max dist edge to srf of .005" and a max angle of 10-15° and see how that looks. Turn on FlatShade and look at the mesh result in Rendered mode (or Shaded with mesh wires turned off) to get an idea of how faceted it will be.

HTH, --Mitch