Split Edges not Smooth

I am trying to model a roadway and when I split the Surface, the edges aren’t smooth following the curve I split. Is there any way to smooth the edge?

The render (display) mesh settings need to be refined. DocumentProperties > Mesh or Options > Mesh.
The default is “Jagged and faster”. Try “Smooth and slower” or experiment with “Custom” settings.