Issue with "shatter" in rhino 7

Hey Guys,

just a generell question, I did a script in rhino 6/Grasshopper and everything works fine.
When I open the same file in rhino 7/Grasshopper with all plugins same installed as in the rhino 6 version, it doesn’t work the same. (change from old laptop/windows10 to new one/windows11)

To be precise, there is a part in the script where I want to “shatter” a curve with the “tA” output of the “multiple curve intersection” just the simplest thing which is working in rhino 6 perfectly, and as soon as I open it in Rhino 7/Grasshopper there are 115 shattered segments instead of 30. So I didn’t change a thing in the script but it doesn’t work anymore just because of using rhino 7.

Just want to ask if someone is familiar with issues like that in generell that rhino 6 and rhino 7 is working different by using grasshopper?
Or is there a special issue with shattering?

thanks guys and best regards

Marc

Moved to Grasshopper category.

Try to disable parallel computing on the shatter component…

Otherwise, attach your file here with internalized data around the shatter component.

Hey Riccardo,

thanks for your answer, tried to disable parallel computing, but doesn’t change.
So here’s the file, big script but I tried to highlight the Issue.
Thanks guys
Rhino 7 ShatterIssue.gh (101.4 KB)