Issue with PanellingTools for Grasshopper

I try to use PT in Grasshopper-Pt surface domain number- is giving an error.

1 Like

Thanks for reporting this. This is an error on our end. @rajaa is working on a fix right now.

Thanks for letting us know.

I could run it fine at first,

but not when updated to the latest Mac WIP

I will have to recompile PT-GH, I think because PT-Rhino was updated with the new SR, but not the PT-GH.

Hi Dan,

Any news about recompiling panellingtools for mac.


Hi Martin!

Sorry for the delay. I had been working on this last week and I am stumped. I’ve enlisted help from others and they are stumped as well. Unfortunately, I’m reduced to caveman debugging this issue this week. I hope to have it fixed soon…long story short: I thought it was a quick fix, but it’s turned into a puzzle.

This is the YouTrack issue number: PT-141, should you want to follow along :wink: Otherwise, I’ll post back here when I fix it and I hope to get it in the next RhinoWIP.


PT-GH for the Mac works now. Just updated the files and instruction…
Let me know if you see any problems


Hi everyone, I recently installed rhino 6 for Mac and I’m having troubles with paneling tools on grasshopper.
When I installed the software at first everything was working but after the last small update I can’t use the “surface domain number” anymore.
The same script works on windows but when I load in my Mac grasshopper it turns red.
I attach an image of the script.

@francesco.luise I see it.
I just want to confirm that it worked before the latest update you did?
Do you use 2018.12.17.0 version (use ptVersion component to check).
Also what Mac Rhino version do you use (I’m using 9/23/2019)?

There is a fix now
Please download and follow the steps described here (under download>PanelingTools for Mac:

Let me know if you have any trouble

Hi everyone i am having the same issues as francesco right now

please if i could get help on this

Hi, Just checking in to see if you solved the problem.

There are instructions to install PT-GH for Mac in older versions in Food4Rhino (6, and should work for 5 as well):