Issue with mapping when bending object with unwrapped UVs

I have a quite complex nurbs model that I have unwrapped. I am currently in need of bending the object. But when I do so the mapping windget doesn’t transform resulting in the uv’s being messed up.
I tried to unwrap the transformed object but for some reason it fails to unwrap successfully even though the seam selection seems correct.
I found an older thread suggesting a different workflow
unwrap the nurbs object
convert to mesh
transform the mesh
edit the UVs

This seemed to work as the texture of the material stays correct in the viewport. But when I try to render the texture is messed up again. If I try to uv edit the mesh object the mapping in the viewport gets messed up as well.

Any ideas of how to overcome this?

Yes, mapping is transformed for only rotation, scaling and translation. Please, could you send the bent polysurface that doesn’t unwrap correctly via this upload page, please?

Hello Jussi,

Thank you for your prompt response. I have uploaded the polysurface as you requested. I think I’ve noticed some discontinuation on a few edges there the result solid is still closed so not sure what’s going on there.

This discontinuation is not present on the original (unbent) object That’s why it’s unwrapping fine

Hope this can give you a idea of where to look

Thanks for the model @Theo

Polysurfaces have tolerances to define how accurately their edges, faces and vertices need to match. So there can actually be visual gaps between edges and yet the polysurface is closed. And some of the tolerances on your polysurface are a little above the absolute document tolerance I can’t see anything too bad.

We are working on improving the _Unwrap command in Rhino 7 so it could handle the bent polysurface too.

Is the texture correct in render after the transform step? Which renderer you’re using?

Thanks for the insight on the tolerances. I’ve been battling to make this model watertight as rail2 and blend srf commands wouldn’t produce matching edges for some reason so I had to adjust tolerances in order to be able to join the resulting surfaces.

That’s great news let hope that it goes into the next build and that the next build won’t take too many years :slight_smile:

I am using vray 3.6 as a renderer. The object renders with the wrong texture coordinates. The coordinates stay correct only in the viewport after I have transformed the meshed version of the object. But if I run and save the uv editor the viewport shows the wrong coordinates as well

Hi Theo - feel free to export problematic objects to a new file and post here (or send to to my (Pascal) attention if it cannot be public). We might be able to help.


Hello Pascal,

Thanks for the response. I have already used some manual workarounds for any issues I’ve had so far. I’am just hoping that some of the automated processes will become more reliable in the future versions.
Thanks again for all the precious help and troubleshooting tips you provide

Also just a small update on the mapping issue. On the uv unwrap command when I select the chain edges option and increase the gap tolerance to 0.01 it seems that there is an improvement and the UV editor command is selectable.
The uv’s are still wrong as some parts are still sticking together on the unwraped mesh even though the seams picked should have detached them. Not sure if this can give you any other hints

@Theo What are the UVW repeat values on Texture Mapping object properties page?