Issue with Copy Command Defaulting


#1

So, this is a relatively petty issue, but it just started recently, and it is starting to drive me insane.

It used to be that all I had to type was “cop” and the default option selected would be “Copy,” and so I would just hit enter and carry on my way. As of about a week ago, when I type “cop” it jumps to “CopyToClipboard” which is not what I want. Is there a way to clear this up so that it defaults to “Copy” instead?

I am attaching a photo that shows what I mean. I have only typed, “cop” and Rhino filled in the rest.


#2

I forgot to mention that I am on an Early 2011 MacBook Pro running Yosemite and my version of Rhino is 5.2.4


(John Brock) #3

Try typing “Copy” to run the command once.
Then see if “Co” or “Cop” runs Copy again.


#4

I could have sworn that I tried that before, but that it hadn’t worked. I just tried it again and it worked. Clearly I just needed you to think about my problem for it to be fixed.


#5

Personally I find ‘cmd c’ quicker :slight_smile:


(John Brock) #6

When you Quit Rhino, I think the Most Recently Used command list is
re-initialized so you’ll need to more explicitly run you favorite commands
to get them on the list.

Windows Rhino works the same way.


#7

It doesn’t do the same thing. “Copy” allows you to copy from one spot to another. Command+C is the default “CopyToClipboard” function that is great for copying elements across files, but less useful within one model unless you are careful about dealing with duplicated elements.


#8

That explains why I was struggling to fix the issue once it started. I’ll keep an eye on that from now on.


(Wim Dekeyser) #9

You might as well make a new alias for Copy right away.

I held off doing so for a longer period but every time you just copy and paste an object from one file to another, CopyToClipboard gets highest on the auto-complete list and forces you to write Copy.
My alias is now just “c”.