Issue when exporting .step files


I’ve been exporting a number files (blocked) from a rhino document in .step. Some of the files export normally, no issues. But some of them show up in the folder with a faded rhino icon, and when I open them the block is placed within a document. If I then explode, the document layer disappears, and I’m left with the original block, but when I try to save that file again, it goes back to the block within document issue. Any ideas as to what is wrong? All the files have been drawn, blocked and exported in the exact same manner.

I hope someone can help. :slight_smile:

Hi @Tale_Berger_Hølmebak I have a hard time following what your issue is. Can you send a sample file that shows issues (both the Rhino file you try to export and the resulting .step file?)

Hi Tale - Do some files have nested blocks, i.e.they are sort of ‘assemblies’ and others not?


First, I’ve only been using Rhino for a couple of months, so excuse me if some of my terminology is off.

So, as I understand it, in the file I export from, the blocks are not nested. I have a file with all my parts, blocked. I then export each file as .step. It’s now the problem arises, as some files export as I would expect, as a clean, unnested block file, and some as a nested block.

So, no I tried opening all the files again, and now all of them appear nested. What I mean by that is that the block lies within “document” (new to Rhino, so I’m not sure if this is the correct terminology).

@Tale_Berger_Hølmebak I don’t see that issue here, I just opened the file you sent by pm

Can you run _SystemInfo in Rhino and copy-paste the result here?

Rhino 7 SR28 2023-2-27 (Rhino 7, 7.28.23058.03001, Git hash:master @ 4ffc5d7156fbccf2a5d9fcc80e522b3851bc7f6c)
License type: Commercial, build 2023-02-27
License details: Cloud Zoo

Windows 11 (10.0.22621 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 5-26-2022 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3050 Ti Laptop GPU (NVidia) Memory: 4GB, Driver date: 1-28-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 511.65
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 1-28-2022
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Stykka\StykkaRhino\StykkaRhino.rhp “StykkaRhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.28.23058.3001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

@Tale_Berger_Hølmebak if you disable StykkaRhino, does the problem persist?

The problem was there before I installed stykkaRhino. (Just installed that plugin last week)

Tried to disable it and export (after restarting), but still get the same issue.

Sorry, I was confused. I see now what you mean. TBH I don’t know why this happens. If I export a single block instance from Rhino it seems to import as a polysurface, your block instances indeed open up as nested blocks. I’ll ask around…

Thanks! It’s a mystery to me to…

RH-74900 Exported block to .stp opens up as nested under “Document”