Export to STEP creates superior block "Document" when containing blocks

Hi there,
I just recognized that when you export a block containing nested blocks to a STEP-File it will create a superior block called “Document”.
When you do not have any nested blocks in it it will not create this block.

Is this behaviour intended?
If yes, can that be switched off?

Hi Tobias - I do not know - I’ll ask if that can be avoided - I suspect not, but I don’t know.

RH-63431 FileIO: Step: Skip writing the document level block

@tobias.stoltmann - the developer said this may or may not be possible but he’ll have a look.


At least it would be nice to have the option if possible.
I think it’s acutally a kind of nice idea to cluster everything in a block, if only the block had the files’s name. That would make more sense, right?

A colleauge of mine just checked the same thing in Inventor.
The result here is the same, with one exception… The block has the name of the assembly there.
So I’d be totally happy if Rhino could simply name the block like the file.