Isometric view skewed/not vertical

I am trying to Make2D an isometric view of a model. I’ve never had this problem in the past but recently whenever I put something into isometric view it doesn’t orient itself vertically. I know I am not accidentally moving the model because I don’t even click the screen. I only use the commands: Isometric > SW / ZoomSelected / Make2D. The angle of the skew changes every time I do this as well. Sometimes it is almost undetectable and sometimes its very drastic. Is this a Rhino glitch or did I unknowingly change a setting somewhere?

Hello - it looks like the command expects the option in Options > View page > Rotate to be set to ‘Rotate around world axes’ - is that how you have it?


Yes it is set to rotate around world axes. Should I change it to rotate relative to view? I am using Rhino 5.

Hello - this works so far here with either View or World - but once the view is tilted off then it is not restored to vertical - you can set the viewport camera rotation to zero to straighten up…

@rajaa - do you know if this is by design for some reason or should that set the rotation to zero?