Isolate Command issue in Rhino 7

Everytime I run the “isolate” command the selection filter turns on. Anyone know why this would happen or how to fix it?

Hi Michael - is the filter completely off - not showing - when you run Isolate? How are you running the command, from a button, or alias or typing directly?


Typing “isolate” directly into the command line. It has the “points” and “control points” boxes selected when it turns on.

Hello - can you please run SystemInfo in Rhino and copy/paste the results here?


Rhino 7 SR16 2022-3-8 (Rhino 7, 7.16.22067.13001, Git hash:master @ aa7902c94c5aa33511e60d30f82b636be43bc85f)
License type: Commercial, build 2022-03-08
License details: LAN Zoo Network Node

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA Quadro P4000 (NVidia) Memory: 8GB, Driver date: 5-6-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 462.59
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1
- Secondary monitor attached to adapter port #2

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-6-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\michael.martin\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\XNurbs (80be33b0-13b2-4ac4-9c77-03829214f9e9)\\XNurbsRhino7.rhp “XNurbs”
C:\Users\MICHAE~1.MAR\AppData\Local\Temp\Rar$DRa17412.20006\elefront421\ElefrontProperties.rhp “ElefrontProperties”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 7\Plug-ins\export_STL.rhp “STL Export”
C:\Program Files\Rhino 7\Plug-ins\export_ACAD.rhp “AutoCAD file export : export_ACAD”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\export_OBJ.rhp “export_OBJ” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\import_STEP.rhp “STEP Import”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\IronPython\RhinoDLR_Python.rhp “IronPython” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\import_STL.rhp “STL Import”
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.16.22067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 7\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Rhino 7\Plug-ins\import_OBJ.rhp “Import_OBJ” 7.16.22067.13001

Hi Michael - I would disable the above plug-ins in Options > Plug-ins page, then close and re-open Rhino - if the problem is gone, re-eanble one of these at a time to see which one is likely the cause.


I do have hotkeys setup for Selection filter, not sure if that makes any difference?

Hi Michael - I would not think so in this case. BTW, the macros that have a ! in front need a space after the !, and for selection filters I would not use a ! at all - this is a Cancel and selction filters are nestable so should not cancel any running command.


Oh nice, thanks. I’ve adjusted the hotkeys. I also asked my colleagues if they have a similar issue and isolate seems to work for them just fine.

Hey Pascal, did you find a solution for this one?

Hi Michael - no - we cannot repeat it so far. Can you please run the command and then copy the last 10 lines or so from CommandHistory (F2 key) and paste here?


So I just did a bit of testing, It seems if i’ve used selection filter recently and press the X to close it (but not checked the “disable” box), it will automatically turn back on if I use the isolate command. However if I do select the “Disable” box within the selection filter and then close it, it doesn’t open back up when using the isolate command.

Hi Michael - thanks - I cannot repeat this so far - if you can, can you please give me the blow by blow, for five-year-olds, to reproduce?


Ok, I was able to repeat on a co-workers workstation. First add a few objects to Rhino, then type “SelectionFilterEdges” which should turn on the selection filter box. Afterwards go ahead and X out of the selection filter box and then isolate one of your objects. The selection filter should pop up at this point.

Got it - thank you.
RH-68303 Isolate: opens the selection filter


1 Like

RH-68303 is fixed in Rhino 7 Service Release 19

1 Like