Bug: "Unknown command $$Isolate$$" when selection filter is on

Steps to reproduce:

  1. Create a curve and select it.
  2. Filter for “control points” only.
  3. Select a few control points of the curve (note how the entire curve is still highlighted too).
  4. Project onto a surface without changing the selection (note how the entire curve is projected).
  5. Isolate.

What happens now if you leave the filter on is that error message.

However, if you are careful to turn the filter off before step 5, you still don’t get anything isolated, yet it appears as if both the projection and the original curves are selected (and the gumball is placed in between both the original curve and the projected result).

Exactly which version of Rhino is this happening with?

Another way to get this error:

image

The latest (as of writing)… V6 SR19.

Ok, I now get this bug even with only curves filtered out and a pair of curves selected.

Is it that the Isolate command actually behind the scenes selects invert in order to hide, and even internally respects the filtering options? :laughing:

This bug is still here, even in the latest V7 WIP.

Can @pascal or @John_Brock or someone please look into this?

@eobet

Please post a specific, detailed example of how to repeat this.

More detailed than my original post?

You can use any document. Just turn Selection Filter Control On and right-click on any object type to filter for only that type of object, select one of them matching the type and attempt to do Isolate.

You should see the error message.

Only with selection filter off (or all object types selected in the filter toolbar) does Isolate work.

I’ve hit this before as well but didn’t investigate. @eobet seems to have ‘isolated’ (haha) the conditions. I can confirm the error message here using:

Version 6 SR26
(6.26.20147.6511, 5/26/2020)
Commercial

Visual Aid:

Model state:

No error:

Error:

You make an incorrect assumption that I am as well versed in the Rhino commands you use as you are.

I do not, and never have used Rhino in a professional setting to design anything.

Yes, I’m familiar was lots of the tools in Rhino but nothing like the depth that a professional user like yourself would be.

Your description would be plenty for someone that routinely uses those tools.
I am not that person, and likely will never be.

I’m not stupid, I am unfamiliar. That’s why I ask for complete and simple explanations over and over and over again.

Well, I think we’re hitting a language barrier here (English is not my native language) so why don’t I just show it in a movie instead:

Thank you
It’s a bit more nuanced that you discovered.
https://mcneel.myjetbrains.com/youtrack/issue/RH-58975

It turns out that Polysurface section must be enabled so the Curves selection works.
If you replace the polysurface with a surface, the Surface must be enabled so Curve selection works.
One other object type in the scene must be enabled for selection or the filter does not work.

Change your filter to only select Polysurfaces, then try to Isolate it.
You’re get the same complaint with polysurfaces.
Very curious
Mikko should have this figured out pretty quickly.

1 Like