Isolate command pops up the Selection Filter box?

I love the Isolate and Show commands, and have created Right Click context menus for using them quickly and frequently.

What I don’t understand is why this Selection Filter box is popping up? I don’t need it and it’s very annoying to close every time I Isolate something.

Thanks

are you still seeing this behavior?

Hi @theoutside
Yea I’m still seeing this and it’s quite irritating.
Version 7 (7.2.21012.11001, 1/12/2021)
I’m using the evaluation version, there is an update but due to newer introduced bugs I’m sticking with the one above for now.

Have you fixed this in the current build?
If I upgrade will that cancel my remaining evaluation days?
Thanks for your help appreciate you asking about this problem.
RM

I can’t reproduce it here, so I’m assuming it’s been fixed.

any chance you have your isolate set up on a macro, or are you using it directly from the command line.

you may want to try the toolbarreset command and start with a clean toolset. ( you will lose all custom bits you have set up, fair warning)

@theoutside
This an old Bug that has never been fixed. I reported it months ago.

Create two or three objects make one sds
Click the select edges checkbox
Dismiss the selection filter box (click the x to close)
Run isolate select any object
For me the selection filter pops up every time after the isolate command is run.

But to end this behavior one has to type or use the _SelectionFilterNone command then the selection filter box does not pop up after the isolate command. But if you don’t use _SelectionFilterNone the selection filter pops up after isolate every time.

Also the select edges command does not have the _SelectionFilterNone on the right mouse button like the rest of the selection icons have, perhaps an oversight?

So I think it’s more of bug with the selection filter, that closing it does not turn it off in isolate’s case. We should not have to run _SelectionFilterNone to circumvent this behavior.
Thanks for your help,
RM

I’m still having this bug!

It went away, but now it’s BACK!!

Command History (F2)
image