Is there something wrong with the model or is it just a glitch?

I noticed that my model in rendered view showed a very pixelated/broken surface, when compared to the wireframe view. Is there a problem in the model or could it just be a “glitch” or a rendering issue in the program?

See attached images, rendered vs wireframe.

The wireframe view looks smoother…

Shaded view shows a little “pixelated” surfaces…You can see that the yellow outline of the surfaces are smoother and the green surfaces does not match with the yellow outline.

What you see is the rendermesh. Besides many other reasons, it can look not so nice when the model is far away from the origin.

So it is just the rendermesh that looks bad, i.e. the render is bad, but the model is good? And what do you mean when the model is far away from the origin?

Please post your file so someone can take a look.


Here it is.

Lochan Urr Topo Lake 1.10000 HobNob.3dm (6.9 MB)


That’s a bit weird. Did you change the tolerance?

Not what I know of…

The original model was in scale 1:1 and I scaled it down to 1:10 000, because I am going to CNC mill the terrain from one piece of wood. And I also changed the units from meters to centimeters, which then Rhino ask if I want to scale the model to the correct size and I think there came up a window with tolerance options but I did not change anything and just went with the default settings.

I extracted the boundary of the lake and trimmed the surfaces again and besides the boundary being a polyline and not a smooth curve it looks fine. It’s not the ideal situation should you want to add a fillet…

1 Like

@Hobnob just run the non-autocompleting TestClearCustomRenderMeshes and switch back to shaded or rendered mode.


Thanks! That fixed it. Altough I am not sure if something else happned?

The surface next to the lake looks wierd. Do you think it will look like this if I CNC mill it or is this just in the render mode?

UPDATE: I think the modell will come out right after in the CNC machine.
The exported STL file looks correct…

That looks to be how the geometry is set up, specifically this corner where lake and shore meet just below the artifact.

If you ctrl-shift select the lake surface and move it ever so slightly down the geometry gets created correctly.

Moved down by 0.003

1 Like

Note, moving down by just 0.001 already is enough

1 Like

Ah okey good to know! Thanks! I just discovered also that the exported STL file might be OK!
See previous updated answer above.