Invalid geometry pop-up alert


(Info) #1

Since the last update (5.4 or 5E407) i’m getting pop-ups to alert me about invalid geometry.
It gives you the options to check “turn off automatic checken”, but that doesn’t seem to work. I keeps automatically checken en giving the pop-up time after time. When i try to remove the invalid geometry, i seems to persist. Even after removing it, it wil pop-up indicating there is still invalid geometry. Which in the end seems to be impossible to remove.
It feels like a bug. I wonder if there is a way to solve or if -in case it is a bug- the bug is being tackled?


Rhino licks
(Pascal Golay) #2

Hello - can you post the file or send to tech@mcneel.com?

thanks,

-Pascal


(Dan Belcher) #3

Similar report here: "Check new objects" window is popping up after every command.

Yes, please send the file. I would also advise quitting Rhino 5.4 completely, relaunching, and seeing what happens.


(Foundafiver) #4

I have the same issue and answered the other thread stating that it’s more prevalent when I’ve imported a non native file (.STEP or .IGS usually from solid works). However, I have just reopened the latest file that gave me an issue (directly opening a .IGS as I did earlier) and have encountered NO problem. As such I don’t see the use of sending you the file? It was a grabcad download in this instance.
When the warning has popped up it follows EVERY interaction - moving any part, scaling, changing the viewport render mode etc etc and checking the box to “turn off automatic checking” has no effect on subsequent pop ups.
Very odd, very arbitrary and very annoying!


(OXII) #5

Ciao,
thank you for your kind answer!
McNeel is having a great support for its customers.
It was doing it with several files strangely.
I restarted the mac two, three times and now it disappeard and seems to work.
In case it startes again I will send you the files.
Best and thank you very much,
Achim


(Dan Belcher) #6

If you can reliably reproduce the issue with a specific file, we would very much appreciate seeing that file. It gives us the best chance of finding and fixing the bug.


(Foundafiver) #7

Likewise. If it happens again I will send the file over as it is.
Thanks


#8

I had the same problem already multiple times. If I use the “select bad objects” command and copy them to a new file the alert does’t show up there. If I close and reopen the original file the alert doesn’t show up either anymore. The alert is very annoying since the turn off option does’t work…


(Danielkreuzsaler) #9

24

Hey people my rhino hangs all the time and my workflow is affected by the problems properly. In addition, this error message comes all the time. please help me it is unbearable. Thank you