Rhi file into Rhino6

unhandled

#1

just upgraded to Rhino6. trying to install RhinoPolyhedra plug-in. I downloaded the rhinopolyhedra6000.rhi file but even when I tell it to open with Rhino6 I get an error saying it is not compatible with the rhino installer engine. how should I run and install this plugin?