Inserted Blocks do not update materials

I’m having issues getting materials to update when I try modifying materials from rhino files that have been previously inserted as blocks. When I insert a model as a block the first time it contains all the current materials but if I were to make changes to the original file the changes do update after “updating” in the block manager.

I’ve just started using blocks so I could use more detailed models. I’m attaching a few images to show how I’m referencing each file into a new one.

So these are the settings I use when inserting the detailed furniture models into other rhino files.

Typically I will start with these then insert them into grouping files similar to this:

I tried outlining where some of the materials did not update in “capture3” as I have updated them in “capture 2”.

Then once I have created larger groups I will insert them as blocks into a “master file” which would be a final model seen in “capture4”

Some of the files I work with are .fbx files (I’m not sure if this makes a difference)… But i’m finding that the same situation happens with a rhino file that has also been inserted.

This is a V-Ray related issue? Looks like Rhino functionality.

It is Rhino - yes. Rhino tries to preserve block materials when you paste/import for some reason.
Even RenderImportConflictOption does not help, it just makes a PBR/Custom material out of the V-Ray material and sets it on the conflicting object. This is not the case if the object is not in a block, and then the conflict option selected is respected.

I would expect Rhino to copy the material, though, don’t know why it turns it to a native material

@johnc you probably know more about this.


I’m happy to look into this, but I will need example files and exact steps to repeat the problem. I would literally need step-by-step instructions of which commands to use and which buttons to press starting from an empty model. There are so many different things you could be doing and I will need to do it exactly the same as you.

If you can’t provide files, could you give me steps for creating my own files?



@brett6 Sorry, I @'d the wrong Brett! Please see my reply above.

I am also having a similar issue. When the file that is being referenced is changed, the file referencing it will not update. I have to go to the material in the new file and make changes there. The file I have is too large to send and contains sensitive information so I cannot send it as is. I tried removing everything except the referenced block, now the block updates in the reference. I am not sure if this information is helpful or not. Here are the settings I use when inserting references as blocks

Hi all, is this issue solved? I recently had the same issue, then I realized that if in my main model, there is a layer named the same as a layer in the block I want to insert, then if the layer in the block changes materials, the combined model will take the setting of the layer in the main model. I simple changed the layer name in the block and it updates now.