Input parameter index [-1] too low for Component Equals Rule - Error

Hey guys,

I am trying to do a Filter operation with Type Name parameter. I am trying to filter all the walls with Type Name equals to Wall 3 but I am getting the error in the picture. Any idea why this is happening?

In this case a Type Filter might work better. Did you make a parameter Type Name? not seeing that available, which is what the error is about.

Fyi, the daily build posted yesterday had some new parameter components :slight_smile:

Yes I saw the new components, will give it a try when I get a spare time.

My question is not limited to this specific parameter though, it is more like a general question. It might be a different parameter, but still gettin the same error.

I think something is wrong with the equals filter (might be the same for other rules too.). Because a definition that worked just fine before doesn’t work now and I get the above error.

Example: Filtering Structural Columns by their Top Level parameter.

Agreed, Its the Value that’s throwing the bug. I’ll add a report.

This was fixed in the v1.0.7884.17134 release.

Hi @Japhy ,

Can’t see it on the daily builds?

I was in the same boat, they are making needed changes to the merge process, just download from here.

that is interesting :slight_smile: thanks @japhy