Infinite initializing on the start screen

Rhinoceros-7 Evaluation version.
16" MBP. Monterey.

On the splash screen,
My license email has been logged in.
However, it stops at initializing and does not start.
Of course, I even restarted, reinstalled, and re-registered my license.

What should I do?

------ More info…

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06342, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Evaluation, build 2021-11-09
License details: Cloud Zoo
Expires on: 4506620-01-05

Apple Intel 64-bit macOS Version 12.0.1 (Build 21A559) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro16,1
Language: en

AMD Radeon Pro 5500M OpenGL Engine (OpenGL ver:4.1 ATI-4.7.29)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4080 MB
Graphics: AMD Radeon Pro 5500M
Displays: LG UltraFine (217dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5500M (4 GB)
LG UltraFine (2560 x 1440)

USB devices
LG Electronlcs Inc.: LG UltraFine Display Camera
Prolific Technology Inc. : USB-Serial Controller D
LG Electronics Inc.: LG UltraFine Display Controls
LG Electronics Inc.: LG UltraFine Display Audio
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices

Third party kernel extensions (3.7.0) 35E739F9-BF6C-3024-A67C-750711B3FB64

Third party plugins

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino “PanelingTools” 7.12.21313.1002
/Applications/Rhino “Displacement” 7.12.21313.1002
/Applications/Rhino “Renderer Development Kit” 7.12.21313.1002
/Applications/Rhino “Snapshots” 7.12.21313.1002
/Applications/Rhino “Commands” 7.12.21313.6342
/Applications/Rhino “Import_OBJ” 7.12.21313.6342
/Applications/Rhino “export_xaml” 7.12.21313.6342
/Applications/Rhino “QuadRemesh” 7.12.21313.6342
/Applications/Rhino “export_OBJ” 7.12.21313.6342
/Applications/Rhino “RDK_EtoUI” 7.12.21313.6342
/Applications/Rhino “Export SVG” 7.12.21313.6342
/Applications/Rhino “MeshCommands” 7.12.21313.6342
/Applications/Rhino “Export_DAE” 7.12.21313.6342
/Applications/Rhino “PDF Export” 7.12.21313.6342
/Applications/Rhino “IGES Export Plug-in” 7.12.21313.6342
/Applications/Rhino “Import_SVG” 7.12.21313.6342
/Applications/Rhino “BlockEdit” 7.12.21313.6342
/Applications/Rhino “Export_AMF” 7.12.21313.6342
/Applications/Rhino “Rhino Render” 7.12.21313.6342
/Applications/Rhino “Import_DST” 7.12.21313.6342
/Applications/Rhino “PLY - Polygon File Format Export” 7.12.21313.6342
/Applications/Rhino “Import_AMF” 7.12.21313.6342
/Applications/Rhino “RhinoCycles” 7.12.21313.6342
/Applications/Rhino “IronPython” 7.12.21313.6342
/Applications/Rhino “Grasshopper” 7.12.21313.6342

My first guess would be to restart your computer.

Rhino has asked the OS to open your Internet browser and check the status of your license.
Everything on our end looks fine.

My guess is Monterey has ignored the browser request.

Any luck?

Oh… There’s still a problem!

It works when it is turned on for the first time after rebooting.
But if I turn off the rhino and open it again, I fall into infinite initializing again!

The only way is to reboot the MacBook and see the template screen normally.
It’s a really exhausting bug. :frowning:

This is the first report I’ve heard of this as a repeatable problem.

What Internet Browser are you using?
Are you running any antimalware tools?

I use both safari and chrome. And anti-malware, anti-virus tools are not used.

I think I just found the cause. Probably!

I use an external monitor for the MacBook Pro.
After rebooting while connected to the monitor, Rhino works well!

When I appear in the “initializing bug,”
I disconnect the external monitor and reopen the Rhino with only a MacBook Pro, and the template screen appears! Working! (without reboot)
However, when the external monitor is reconnected, and the Rhino is opened, the ‘initializing bug’ occurs again.

Since login is always good, it seems to be a hardware bug, not an Internet problem.
In my case, it is related to the external monitor connection status.

I tried many times and the same result. It’s weird, right?

In addition, there is an usb port in the external monitor (LG UltraFine 5K), but all of them are empty. One Thunderbolt 3 cable supplies power and display.