Rhino 7 Trial won't launch

Just gets stuck on “initializing”. I read some posts about deleting preferences and looking for hidden alert windows but no success. 16" MBP running 10.15.7. It looks like it is “Getting license from license manager”—could there be a preference on my Mac that is stopping it from getting through to the server. I don’t think it is my network because the app runs fine on another Mac.

Have you tried restarting your Mac, this may refresh the ability to connect to the license server. Also, are you opening a specific file or starting Rhino 7 without a file? Did Rhino 7 ever run on this Mac as well?

Yes on the restart. New Rhino install.

It sounds like you may have tried deleting your plist preferences file already, is that correct? Instructions to do this are here… Rhino for Mac - Preferences [McNeel Wiki]

Did you have some other version of Rhino on this Mac before? Does the Mac meet the system requirements? Rhino - System Requirements

Also, are you opening a specific file or starting Rhino 7 without a file?

I had deleted them before manually. But trying just now with your Wiki article, terminal says “Domain (com.mcneel.rhinoceros7) not found. Defaults have not been changed.” It sounds like my Mac cannot contact your server and therefore the startup hangup.

It’s one of the latest and fastest 16" MBP so I assume I meet the specs. Possibly had an older version of Rhino on here years ago.

Not opening a file. Just booting Rhino by itself.

Maybe this:

We’re guessing without a screenshot of an error.

Thanks, John. That partially fixed it. Now Rhino attempts to log me but then throws up this error:

Yup, that’s it.
The fix is resetting your screwed up localhost file.

That is actually what it looks after following that fix for the host file. So, I must have something else in addition blocking the license check.

Hey @eande, did you reboot the machine after fixing the /etc/hosts files?

Can you try opening Terminal.app, paste the command below, hit Enter and send us a screenshot of the result?

ping -c 1 localhost

You should see something like this…


Hi, yes, rebooted.

Tried fixing the hosts file again just in case. Still no dice.

Screen shot attached.

Thanks, that confirms that /etc/hosts is correct and the loopback interface is up. The browser is being redirected to a local web server hosted by Rhino as part of the authentication flow, but Rhino isn’t listening. Very strange.

We may need to do a remote session to investigate further. Please email tech support and we’ll continue this there!

Hi @eande, did you ever manage to get Rhino to work for you?

RH-64921 is fixed in Rhino 7 Service Release 11 Release Candidate