Rhino 7 might be crashing the MAC OS


I would like to check if other users are experiencing the same issue with Rhino7 for MAC.

Since I upgraded my OS to Monterrey, my Mac screen freezes suddenly, with the impossibility to do anything (not even reach the force quit command), with sometimes just restarting by itself.

Recently, when on Rhino, it happens continuously right after opening a file, sometimes after few minutes only.

I have been calling the apple support, with the ultimate option was to redo a Clean install of the OS.

Since then, I haven’t been experiencing any crash, unless on Rhino ! so I am wondering if the issue comes from there…

Something I noticed:
When the wheel keeps turning forever once Rhino freezes, if I push Command+Tab to navigate between apps, I can see on the Touch Bar that I am on an another app (say, Mail)… while Rhino is still blocked on my screen.

Please let me know if there is anyway 1) to fix this, 2) to identify clearly the source of the problem 3)if it is definitely a Rhino app issue.

A system report just in case, with my very best… :

Rhino 7 SR16 2022-2-8 (Rhino 7, 7.16.22039.15002, Git hash:master @ 03d9447136d66e554d335bfc7e790f06e19f7485)
License type: Educational, build 2022-02-08
License details: Cloud Zoo

Apple macOS Version 12.2.1 (Build 21D62) (Physical RAM: 32Gb)
Mac Model Identifier: MacBookPro15,1
Language: en-JP (MacOS default)

AMD Radeon Pro 560X OpenGL Engine (OpenGL ver:4.1 ATI-4.7.103)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: Radeon Pro 560X
Displays: Color LCD (258dpi 2x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
Radeon Pro 560X (4 GB)
Color LCD (1680 x 1050)

USB devices
Apple Inc.: USB3.0 Hub
MOSART Semi.: 2.4G Wireless Mouse
Apple Inc.: USB-C Digital AV Multiport Adapter
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices

Third party kernel extensions

Third party plugins

Rhino plugins that do not ship with Rhino
/Users/ghalibouayad/Library/Application Support/McNeel/Rhinoceros/packages/7.0/ProRender/ “ProRender”
/Users/ghalibouayad/Library/Application Support/McNeel/Rhinoceros/packages/7.0/AMDDenoiser/0.5.0/AMDDenoiser.Mac.rhp “AMDDenoiser.Mac”
/Users/ghalibouayad/Library/Application Support/McNeel/Rhinoceros/packages/7.0/Bullant/ “bullant”

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.16.22039.15002
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.16.22039.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.16.22039.15002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.16.22039.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.16.22039.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.16.22039.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.16.22039.15002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.16.22039.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.16.22039.15002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.16.22039.15002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.16.22039.1002

The generic suggestion for reports of the OS problems is to try running Rhino with the plugins that did not ship with Rhino not loaded and see if that resolves the issue. If the issue is resolved then try running Rhino successively loading the plugins until the problem reoccurs. That will identify which plugin is causing the problem.

Hi -

Have you tried running with these plug-ins disabled for a while?

1 Like

@wim @davidcockey thank you for your swift reply. I turned off the non-native pluggings, I will keep you updated on this one in the next few days!

With many thanks,

I have same or similar problem.
I dont have any plugins installed…
get same result every time:
Mac OS Monterey 12.0.1

  • fresh rhino7 install.
  • try to put license.
  • program crashes.
  • none of the buttons in license manager work…

Hi -
When Rhino crashes, is there a Rhino crash dialog that lets you send in a report?
Can you provide your Mac hardware information?

hi wim

I have Monterey 12.0.1 running on a 2019 Macbookpro.
2.6 GHz 6-Core Intel Core i7
16 GB 2400 MHz DDR4
Radeon Pro 555X 4 GB Intel UHD Graphics 630 1536 MB

Up now i got the problem resolved after multiple tries.
i went to the website added the licence to zoo and then tried registering my app again. That solved it for me. but all other options to put the serial number wer not working.

@gari.kun Sorry for the frustration here. This is a crash bug that snuck into 7.17 on both the Windows and MacOS versions. It happens when launching Options > Licenses > Change License > Enter License Key. It is fixed in the latest service release candidate 7.18.

You can also bypass this bug in 7.17 by using Options > Licenses > Change License > Remove License first and then entering the new license once the license wizard starts up and asks for the license again.