Importing tff file not working?


#1

Hello every one.

Does anyone know why these off files are not working ?

Ive downloaded three separate fonts and all say there are three errors with them and they show as a question mark in a box ?

This is a link to the last file I tried.

Running OS 10.12

Cheer’s

Glenn


(John Brock) #2

This isn’t a good place for this sort of question as Rhino just uses the fonts that are installed in your operating system (OS X/macOS/Windows).

If you can install that font into your Mac, then when you start Rhino, it should be available.


#3

Yup, Know that.

Its not working though. Shows up in my system but not in Rhino.

Hence - Posting in Rhino.


(John Brock) #4

I’ll fire up my Mac and see if I can get it to work.


(John Brock) #5

I think the font definition is bad.

I opened the font in macOS Sierra using the Font Book application.
When I clicked on the install font button, it griped.
I opened the details in font validation and it listed three problems:

  • ‘name’ table usability
  • ‘sfnt’ required tables
  • ‘name’ table structure

Did you not see these problems when you tried to add it to your Mac?


#6

Yup I saw them.

Thats why Im asking what the problem is. Is there a fix or a work around ?

Cheer’s

Glenn


(John Brock) #7

Not in Rhino, no.
The problem is with the font definition.
If the font imports correctly into OS X, then downstream Rhino can use it.


#8

Free fonts are hit and miss. You’re never going to get a quality font on a site like that (e.g., on that supports OpenType features).

If you want to fix this, you need to get a font editor. See if it will open the file and save it correctly.


#9

Its strange because in Font Book they displayed ?

Ah well thanks for explaining.

Glenn


(John Brock) #10

Yes, but when you install that font into your Mac, you get the errors I listed and are admonished to not use the font.
It’s rubbish in it’s current state.


#11

Aha. Yes admonish they do :slight_smile:

Thanks John.