Importing .rhi plugins?


#1

I’ve been searching all over the forums, but I just don’t find an answer concerning compatibility between WIP and .rhi files.

Anyhow, I would like to install the Clipper plugin in WIP. Is that possible?


#2

just double click it and it will install
but some plugins will only work with rhino5


(Wim Dekeyser) #3

Only plug-ins built on the RhinoCommon SDK are checked for compatibility when you try to load them in RH6. If the functions that are called by the plug-in exist in the current (RH6) version, the plug-in will load. In all other cases, plug-ins compiled to older Rhino versions will not work.

More info in this thread:


#4

Then it will install with version 5. How do I make WIP at least attempt installation of the plugin?


(Pascal Golay) #5

Hi Felix - here this appears to install a version for 6.

-Pascal


#6

here not


(Will Pearson) #7

@feklee whilst Rhino WIP does indeed load compatible, outdated RhinoCommon plugins I only just got round to tweaking the Rhino Installer Engine (rhiexec) to allow V5 plug-ins to be installed for Rhino WIP. I also added some extra information to the dialog, as seen in Pascal’s reply above. Unfortunately last week’s WIP was delayed but hopefully we’ll get one out today/tomorrow which will include the new version of rhiexec :+1:. If you can’t wait, then rename the .rhi to *.zip, extract it somewhere and drag-and-drop the .rhp into Rhino WIP to load it!


(Pascal Golay) #8

BTW, @feklee - the plug-in did not actually load in V6 - at least not here in our daily builds, so you may end up needing to chat with the plug-in developer.

-Pascal


#9

Thanks for letting me know, Pascal. I contacted the developer now.


#10

Sure, I’ll have a look at it this weekend to see if I can make a V6 build.


#11

Ok, there’s a new version up at food4rhino


#12

Tried it out, and reported as a comment on: http://www.food4rhino.com/app/clipper-grasshopper

It could be that I discovered a small Rhino bug:

  1. Dragged the .rhp file into WIP, got informed that it’s blocked.

  2. Unblocked the file using the Windows Explorer file properties.

  3. Dragged the file again into WIP, and again I got informed that it’s blocked.

In the end I restarted WIP, and then it worked.


#13

That was quick! I successfully installed it, as follows:

  1. Downloaded: http://www.food4rhino.com/system/files/users-files/arendvw/app/clipper-022-rhino6.rhi
  1. Renamed clipper-022-rhino6.rhi to: clipper-022-rhino6.zip
  1. Copied the contents of the zip archive to: C:\Program Files\Rhino WIP\Plug-ins\Grasshopper\Components
  1. Unblocked ClipperPlugin.rhp via file properties in Windows Explorer.
  1. Restarted WIP. (necessary, or else it would still report that the rhp file is blocked)
  1. Dragged ClipperPlugin.rhp into Rhino WIP.

Now for testing, which failed:

  1. Started Grasshopper.
  1. loaded a file that uses PolyOffset, and which works in Grasshopper for Rhino 5. In Grasshopper for WIP, that component gives me an error message: “1. Solution exception:Could not load file or assembly ‘ClipperTools, Version=0.0.2.1, Culture=neutral, PublicKeyToken=null’ or one of its dependencies. The system cannot find the file specified.”
    Submitted by feklee on Wednesday, February 15, 2017 - 22:49

Replying here, it’s a bit easier:

Possibly the ClipperTools.dll are still blocked, can you check? Both grasshopper and rhino need this file. Also, possibly there’s still an older version in another place. I’ve just released a new version (0.2.3) that is also built against the newer grasshopper (although the other one should also work).


(Brian Gillespie) #14

RH-37982 is fixed in the latest WIP


(Will Pearson) #15

Just to let you folks know… starting with the WIP that went out today, the Rhino Installer Engine will install V5 rhinocommon plug-ins for Rhino WIP (as seen in Pascal’s reply above). :tada:

These plug-ins get checked for compatibility with the RhinoCommon SDK the next time you load Rhino WIP. As it turns out the compatibility checker was being a tad over-zealous but, as Brian notes above, that’s now fixed!

@arendvw Sorry you had to go to the trouble of re-releasing your plug-in. I hope that these changes will save other developers from having to re-compile plug-ins just for the sake of re-compiling! Although I see you took the opportunity to do a little maintenance :slight_smile:


#16

Thanks for the update!

On a related compatibility note: do rhi files for mac require anything different? Or should they be ok if they do not require any native libraries?


#17

That was it, thanks!


(Will Pearson) #23

@arendvw Sorry for the delay.

Please take a look at the guide to plug-in installers in Rhino for Mac. You’ll notice that things are a little bit different between platforms. If you also add the GHA to the RHP bundle then Grasshopper will load it.