Importing PBR Materials not working

When I try to import PBR Materials, Rhino hangs and I need to shut down. I have done it a few days ago (once), but I cannot do it since the last update (yesterday?).
Thanks, N

Do you have the zip file or set of textures you are trying to import?

I tried both.
I tried with materials downloaded from CC0textures and with materials created with Adobe Capture.
A few days ago, I was able to import a material created with Adobe Capture, imported as a zip file - if I remember correctly.

The problem is not only the inability to import the material, is that I need to shut Rhino down via the task manager. I normally wait 10 minutes.


@nsgma To clarify, Andy was asking for the actual materials you are seeing problems with so we can test them here.

Oops. Sorry, I misunderstood.
It happens with all, one of them was (10.6 MB)

In the meantime, because of other problem with scripts, I did a repair of the installation, but the problem persists.

That material one worked here, in the latest - I used both the Surface mapping and WCS/OCS options.

( Looks like there is a typo in that dialog… I’ll get that on the pile at least. RH-60543 Typo in PBR dialog)


Hi Pascal,
I tried again and repeatedly “import from material library” and “create physically based material from texture files”.

I also tried “Create new material” >> “physically based” >> detailed settings and when I selected the textures it freezes.

I never got to a dialog box beyond indicate which zip file to use.

I also found the very first PBR material that I tried (and worked) before the last update, but also did not work. Unfortunately, I did not save the rhino file of that test.

Any other ideas?

Ignore the issue below. The issue was that the displacement map was scaled to 100 and therefore even when I zoomed to extents I was still “inside the sphere”.

the strike-through format would come handy below.
Further to the previous post, I tried to insert the texture manually one by one.
That worked but there’s something not really working with the rendering.
See below.


It is certainly working here in every build of Rhino I try. Would you be interested in having a developer run a remote control - and possibly remote debugging session - on your machine to try to figure out what causes this?

Another piece of information that would be useful - could you run the RenderReportMissingImageFiles command in Rhino and see if the dialog shows up for that? (it doesn’t matter if you don’t have any missing textures - I just want to know if the dialog shows up)

  • Andy

Hi Andy,
A dialog appears after RenderReportMissingImageFiles (see below).
We can try a remote control. how do we organize that?
I have a couple more issues with rendering materials, but I am wondering if it is all connected so I’ll wait to post about it.

Email me directly at and we’ll set it up

Hi Andy,
I found the problem. I unplugged my second screen, which made everything collapse on to the main screen and the dialog box appeared. So the dialog box was there somewhere all along but out of bounds of both screens. When escape is pressed it does not go away and perhaps I haven’t press enter (??).
When I re-plug my second screen, it is out of bounds again, but now I managed to see a little corner peeping on the top left screen corner and was able to bring it to the screen.
Almost happy with that, I imported a second material but again the dialog went out of bounds, this time totally (no peeping corner). Unplug screen and there it is again, re-plug and it is still there.
After a couple more tries, I realized when rhino is in one screen it works when rhino is in the other screen it doesn’t.

I’m going to forward this to one of our UI guys to see if they can help

Hi @nsgma,

I’m looking into this and found something that could perhaps cause this issue, but I’d like to verify given your exact scenario. Could you go to the windows Settings app, and navigate to System > Display, and tell me what scale/DPI you have for each display? e.g. 300% for second screen, 100% for primary screen, etc.

Also, could you take a screenshot of the layout of your displays, for example the following:

Screen Shot 2020-09-25 at 1.39.30 PM

Finally, could you identify which screen you are using Rhino on?


Thanks to @curtisw great investigations and instructions I have made a fix for this and committed it. Hopefully it works. I will keep the item in “needs testing” state.

The fix should be in the next WIP. @nsgma It would be great if you can confirm that it works when you get the next WIP.


@curtisw @maxsoder
sorry, I have been away from the Rhino testing for a few days. I’ll have a look at this today or tomorrow

Hello @maxsoder,
After the last update, the problem persists.
201007 Bug PBR import 02
here is the display layout. The problem happens when Rhino is on screen 1.

@nsgma Thanks for testing. Did you try this with the lastest Beta release?

The dialog stores the size and the location of the dialog when it is closed. Have you tried to open the dialog and close it only using one display. Then it should store a location that is correct. Then one could try to test with 2 displays and see if the problem still occurs.

I reopened the YT issue.

Br, Max

Hi Max,
I was going to start Rhino and I have noticed I have Rhino WIP and Rhino BETA. Which should I use to test and why isn’t the other deleted?
Thanks, N


I think the WIP should have been replaced. At least for me the Beta replaced the WIP.

You should use Beta to test.