Importing PBR materials stopped working

Latest Service Release : Rhino 7 SR12
Whereas before (i.e. from Rhino 7 onwards) if I dragged my PBR .zip file onto the model directly, it would open a dialogue requesting scale etc for the pbr texture… now all I get is an ‘file import’ dialogue.

in fact if i try and import via the materials dialogue (i.e. by adding a material)… and select ‘import from materials library’ and then select ‘physically based texture files’ as the file type I get the following error dialogue box displayed ‘file type zip cannot be loaded as content’

I am using the same texture files (from as before ( I had them saved on my hard drive so I know they worked in SR11)

I tried running ‘repair’ install. Which ran successfully but made no difference

edit : If I run ‘Create Physically Based Material from Texture Files’ from the Materials menu… and point at the .zip file it works fine, and I see the dialogue I expect to see… So it’s just the ‘drag and drop’ functionality which seems to be broken (on my machine)

Am I right to think that I’m the only one seeing the behaviour ? If so I’ll raise a support ticket
I tried installing the bloatware that is Autodesk Dwg Viewer and then uninstalled 2GB of application once I realised you couldn’t even read a dimension using that programme…
However the issues with pbr may have been triggered by the uninstall

Hi -

No, I see that here as well. I’ll have to do some digging to find out if that is by design…

1 Like
I just logged a bug for this here.


Ah ok. That’s good (that is not just me :wink: