Importing existing .3DM files to open project

When I try to import .3DM models into an open project more often than not they’re greyed out and I can’t select them.

I can work around it by searching for the file using spotlight, opening it and then copying/pasting it into the current window but that seems like an awfully long winded way to do things.

Is this a known issue or am I doing something wrong?


Hi Anto - I do not see that happening here. I’m not sure what to suggest - do you have the Import dialog looking for ‘All readable files’ or 'Rhino 3D Models(3dm)?


Thanks for the reply Pascal.

I’ve tried selecting file types individually and using all file types with no success.

It’s very odd and I don’t see an immediately obvious reason for it.

I guess I’ll have to see if I can change some settings and get it working.


worth a shot…

open Finder then go to finder Preferences…
under the ‘Advanced’ tab, make sure ‘Show all filename extensions’ is active.

(just suggesting this since your screenshot doesn’t have the rhino files as .3dm… that said, the icons are at least generic rhino icons so this suggestion probably won’t work)

Thanks Jeff!

Thats definitely my problem but I don’t seem to be able to show all extensions. I’ve enabled it as shown and restarted my computer, but in ‘get info’ on the files it says ‘hide extension’ and as I say, showing all hasn’t actually achieved the desired effect.

I will try to correct it, but thank you very much for pointing that out.


yeah, i don’t know what to suggest.

out of curiosity, what happens if you manually add the extension to one of those files? try renaming to PearlCufflink1.3dm then Import.
Does Rhino now recognize the file as a valid import?

I tried adding the extension as you suggested, but discovered in ‘Get Info’ that the extension was still being hidden and now I’ve manually unchecked that box they can be imported.

I have over a hundred 3dm files that aren’t showing their extensions so this could take a while to correct.

I don’t know why some show and some don’t because hiding extensions isn’t something I’ve asked my computer to do.

Again, thank you for your help. It was baffling me.