FIle 3dm mac not open in windows (solved)

The file I have been working on for 3 years with my Mac does not open or import on my new Windows pc (n only a few layers). Messages appear during import: file unreadable, construction history not readable, fonts not supported. I have extracted all invalid surfaces, deleted all the construction history but it was not enough. I need to solve this problem as soon as possible. I can’t send the file, I need to solve it with a solution . Thank you for your understanding. Rhino 7 file.

Hi Simon -
Without a file, it will be hard to suggest anything specific. It sounds like you are getting something into Rhino… Missing fonts is common when using different platforms. Does the file still open fine on Mac?

Hi Wim.
The file on Mac works perfectly. I ran the _purge command and also deleted ( just in case) the background images. This morning I used on Rhino WIndows the command “recover 3dm” and I managed to import almost all the secondary parts but not the basic structure ( fuselage of a helicopter). Everything was imported in one layer. Just as I’m writing I created a file from Rhino Mac with only the missing parts, I used the command “extract invalid surfaces”. In this way (after three unsuccessful attempts) I was able to import the missing parts but also a huge amount of surfaces used only for cutting and curves were imported (apparently it’s as if the command “extract all surfaces with keep cut objects” was executed). I am trying to figure out how to import all the layers. I have saved several reports that I can send if they can be of any use. As a long time Rhino Mac user, I am aware of the need to send a file but it is not possible. I can send any information about the sitemes I use, reports or anything else if it would help.

Hi Simon -

If I understand correctly, you are not crashing and those would not be crash reports, correct? If so, I don’t think those would be of any use, no.

Yes, no crashes

Solved by exporting the file in Rhino 4 format.


Hi Simon,

I appreciate that you may not have time to explore this further but as there would seem to be an unresolved compatibility issue between Mac and Windows, it could be helpful to know whether

a) using the Save Small option on your original file creates something that works in Windows
b) creating a new R7 file on the Mac and importing the original file into it, and saving, does so.

If the import approach does not give you a working Windows file, might you be able to import a small element of your original model to produce a new file that displays the error but is sufficiently innocuous to allow you to share it privately with McNeel for their use in diagnosing the root cause of the problem?


Important update.
I saved my file (1.7GB) in V7 version on Rhino Mac with the “Save Small” command. I point out that I removed the analysis meshes, all bitman images, repaired all invalid surfaces and manually repaired all problems on files converted to mesh, Ultimately all nurbs and meshes gave in the command >Analysis>check , closed and valid objects.
I tried to open the V7 Small Rhino Mac file on the Windows computer and it worked, correctly importing all layers ( over 140).
The file was opened in Wireframe mode and to switch to shaded mode took about 7 minutes ( I guess Rhino had to create the shading from scratch the first time).
Side note: for sharing the .3dm V7 file between Mac and Windows I didn’t use the ssd share connected to the router that was giving me authentication problems, but the “Normal” shared folder share.
I hope this information will be helpful to someone.
Thanks Jeremy


1 Like