Import OBJ Textures Wierd

Ah, OK - I do not see anything like that yet - just to be sure, you see this in Rendered display mode, correct, but not in a full render or raytraced vp? What happens if you UnifyMeshNormals?

-Pascal

Correct. UnifyMeshNormals has no effect.

Hi Robin - please run SystemInfo in Rhino and post the results - this is feeling a bit video-card related to me…

-Pascal

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09492, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Commercial, build 2020-12-08
License details: Cloud Zoo

Apple Intel 64-bit macOS Version 10.16 (Build 20C69) (Physical RAM: 64Gb)
Mac Model Identifier: MacBookPro16,1
Language: en-GB (MacOS default)

AMD Radeon Pro 5500M OpenGL Engine (OpenGL ver:4.1 ATI-4.2.13)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: AMD Radeon Pro 5500M
Displays: Color LCD (264dpi 2x), DELL U2715H (109dpi 1x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5500M (4 GB)
Color LCD (1792 x 1120 @ 59.00Hz)
DELL U2715H (2560 x 1440 @ 59.00Hz)

USB devices
Realtek: USB 10/100/1000 LAN
Apple Inc.: iPad
CalDigit, Inc.: CalDigit Thunderbolt 3 Audio
CalDigit: Card Reader
Seagate: Expansion
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Nordic Semiconductor:
Apple: AAP Server, Audio Sink, AVRCP Controller, Handsfree, AVRCP Target

Third party kernel extensions
com.intel.driver.EnergyDriver (3.7.0) 35E739F9-BF6C-3024-A67C-750711B3FB64

Third party plugins
/usr/lib/swift/libswiftAppKit.dylib
/usr/lib/swift/libswiftCloudKit.dylib
/usr/lib/swift/libswiftContacts.dylib
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreData.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.1.20343.9492

Hm, I do not see any of this on Mac either. It does seem like a display thing and not an import thing - can you please save off, with its texture just one of the meshes that shows the problem, make sure the new file still looks incorrect, and send me that?

-Pascal

OK, this is really very strange.

The act of exporting the problem meshes and opening the exported file fixes the problem. It doesn’t just fix it in the exported file, it fixes it in the original too even without having to close and reopen the file.

I’ll try to record it happening.

Edit: here it is in all its glorious weirdness:

I am doubly mystified - does the fix then stick, in the original file, if you close Rhino and then reopen it??

-Pascal

I haven’t tried. But I will.

Also, I’ve got a couple of other glitches on my Mac that apple think are hardware related and I need to take it in to be repaired. Do you think it’s conceivable this is a hardware issue?

The fixed textures stay as long as the original file is saved after the ‘fix’. If it isn’t saved then when reopening, the blue patches reappear.

After saving, it seems to be permanently fixed. I tried:

  • Quitting rhino and reopening
  • Restarting Mac and reopening
  • Quitting and deleting the exported mesh and textures then reopening

All resulting in the main file opening and displaying the textures correctly. At least I now have a work around whilst this is investigated further.