Missing textures when exporting as obj.?!

I am trying to export a few models as an obj. During the save options, hit hit save textures. The issue seems to be that I am limited to about 10 or 11 textures that will save. I am trying to upload these obj. models with its textures to SketchFab model viewer. CAN ANYONE HELP PLEASE?

Do you have a sample 3dm file as well as the textures used? Also, what renderer and material definitions are you using? This may be a factor but if some of the textures are found that should help figure out what’s happening for those that aren’t loading. I haven’t used the model viewer you mentioned but do you see anything different in other programs that can read obj files and the corresponding mtl file which references the texture maps?

2nd.3dm (19.4 MB)

Hi Brain,
The renderer that I a, using is just the standard Rhino viewport renderer. I have V-Ray, but it is currently on Rhino Renderer. I’m not quite sure what you mean by ‘material definitions’. I tried to mess with making the objects a ‘parent’ rather than applying the material as to the object; which is what I typically do. So, under Properties, I go to Material, and then I upload my texture image under ‘Color’ (which is under Textures).
I;ll attach a link to the SketchFab model. The issue is not will SketchFab though. I know this because:

  1. I can see all the textures that are supposed to be saved are missing, and the ones that are missing are the one’s that do not upload to SketchFab. I even try to add the missing texture images to the SketchFab upload, and that does nothing.

  2. I tried to import the obj. file into a new 3dm. file, and the result is has the same missing materials/textures as the SketchFab upload.

The attached 3dm. may not match up the the SketchFab model in this case because I messed around with the 3dm. file a little after the SketchFab upload.

Thank you for the response. Hopefully I was clear enough. My terminology isn’t the best. Also, if you need me to upload the obj. etc…, please let me know where is a good place

Thanks for the file. The 3dm didn’t have the texture maps embedded in it via Options>Document Props>Rendering but I did see a few textures which might explain the issue. The issue might be block materials but I’m not sure. The coffee table for instance is made up of block instances nested inside a block instance. Check out object properties>material>by object, when the table is selected. The texture map for the color channel is missing but you can see it in the Rhino viewport. If you Explode the table twice you’ll explode the blocks into the original mesh objects. This might fix things if those are the problem spots… it’s hard to say since you said the 3dm won’t match the sketchfab model.

Another thought is to remove any spaces in material names… this sometimes causes issues moving textured models as obj.

If this doesn’t help, save the 3dm again please with the textures embedded and indicate which objects are missing the maps when saving them as obj and importing to sketchfab.

I meant the active render plugin’s material. Sometimes this is called a material definition and the different renderers use unique names for material attributes which might have been involved.

Hi Brian,
I saved my 3dm. file and hit the save textures option while doing so. This is how I would embed the textures, right? The new one is attached. I also reloaded the obj. file to SketchFab that came directly from this attached 3dm. If you compare the 3dm. to the SketchFab model, you should be able to see the differences.

The file names/ textures that are missing are

tile.jpg
ME09E71.JPG
l.PNG
counter.jpg
65430L1.JPG

I considered this, but the table texture is not the one that is usually missing[quote=“BrianJ, post:4, topic:27950”]
Another thought is to remove any spaces in material names… this sometimes causes issues moving textured models as obj.
[/quote]
I looked at the image files, they had no spacing. At least the ones that have a ‘-’ are not usually missing

I CANNOT UPLOAD MY 3dm. FILE. IS THERE A SIZE LIMIT? IT’S 24 MB

Please email to tech@mcneel.com or use www.rhino3d.com/upload

make sure to put this forum post link in the comments please. Or just Export a version of the 3dm with only the objects in question and post here.

Thanks for the uploaded file. I isolated an object with the tile material and used Export on just this surface with the obj export settings shown. The obj and mtl file are working here in Blender (with Blender Render) for comparison.


I don’t have experience with SketchFab but are you using the same settings? Just select this one surface and use Export to upload a test to sketchfab.

I also noticed that the latest sketchfab model doesn’t match what I see in Rhino specifically for two of the textures you report are not transferring… counter.jpg and ME09E71.jpg

There are a bunch of unused materials in the Rhino file too that may be confusing matters, use the Purge command to remove 46 unused v5 materials as another test and try exporting again.

One last thing to test, does the obj you’re saving import into Rhino with the textures? Again isolate just one problem object to keep things simple when testing since you know which elements are missing their textures in sketchfab.

Uploading…
1- I found that isolating an object and exporting it to obj. with saving textures was only unsuccessful once, so it didn’t solve anything as far as why I had several missing textures.

2- I used the purge command to clean unused textures. This may have helped a bit, but it did not solve the missing textures when exporting to an obj. file.

3- When I import the created obj. file back into Rhino, it is missing the same textures that did not export with the image files, obj. file, and mtl. file when exporting.

4- I erased all the materials on the files memory and organized almost all objects to a layer. I made those object’s material properties to be defined by ‘layer’. I then designated each layer to its proper texture file. This finally got me to about 1 missing texture when exporting to obj. I re-exported about 15 more times; each time having no consistency in the total amount of textures that exported successfully. Finally, with no apparent explanation, all textures exported over and I was able to upload my model to SketchFab successfully.

I greatly appreciate your help with this, I learned a thing or two. I do not think I know how not to have this issue again, unfortunately. I do have one more model to upload to SketchFab, and it contains more textures than this model we were working with at the beginning of this thread. Are you employed by Rhino? Is this just a something that cannot be prevented currently?

Yes, I work for McNeel but I’m not able to reproduce this to file a bug report for the developers so far. The ideal scenario would be a single surface that when exported as obj doesn’t get the texture name written to the mtl file. If you come across something repeatable please let me know via tech@mcneel.com

The fact that it suddenly works makes me wonder if it’s possibly a memory issue on the system. It’s a total guess mind you and may well be completely off base.