Images become distorted beyond use in Viewport

Images are still going wacky when working in rhino first it was picture planes now this; a similar problem with images on a plane and with transparency set on, see image. Trying to make a few alpha channeled trees and when I move or edit this smearing happens. Looks to me like the box mapping is kicking on and off as well or that the material mapping is getting messed up in the redraw of the screen. It sometimes goes away with an undo or a move only to reappear on another random plane and different material. Working at first in rendered view but still shows in other view modes.

I keep having the same issues where the texture maps on flat surfaces at random get completely messed up, look like stretched 1000% in one direction. Then they go back to normal, only to get messed up again. Rendered mode. Hard to reproduce exact steps and it always looks ok after saving and re-opening the file.
Updating to latest video drivers did not help.


Yea its been there for a while I finally got tried of it and decided to post on it again though at first it was on picture planes. I think its the mapping pipeline because I saw the image turn into box mapping at one point as well.

Hi @3dsynergy,

Which Rhino 6 version do you have? Please paste the contents of Help -> System Information....

When the problem happens, delete all other objects. Does the problem now correct itself? I’m trying to figure out whether this is something that I’ve already fixed in a later version of Rhino.

Finally, a video of the problem and/or a 3dm file which often causes the problem would be very helpful.


Hi @DavidEranen
I’m beginning to think this has to do with v5 or older files and it is intermittent. I haven’t had it happen since I posted at that point it was pretty annoying, thankfully it’s not happening.
I wrote over and changed the file it was happening in and changed older materials to new ones. I was getting the bug applying a .png file as a texture with transparent background.
Next time I run into it I’ll email you the file before I do anything to it.
Thanks for your reply and help,

Rhino 6 SR13 2019-2-27
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

Hybrid graphics system.
Primary display: Intel® HD Graphics 530 (Intel) Memory: 1GB, Driver date: 7-24-2017 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 960M (NVidia) Memory: 4GB, Driver date: 8-13-2018 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 399.01

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 8-13-2018
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
E:\Downloads\elefront411\ElefrontProperties.rhp “ElefrontProperties”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.13.19058.371
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\WebCam (b03d9978-150a-4297-95e0-d8a50df7c0b0)\\WebCam.rhp “WebCam”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.13.19058.371
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”
C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\SectionTools (fbdb1d7f-8cfb-42c1-9858-87cb6315932c)\2017.10.11.570\SectionTools.rhp “SectionTools”