I have a problem with Surfaces created in Solidworks

My question is simple.How to get the surface actually to trim to the yellow border? I tried to use rebuild command but it didn’t work?

Hi Denis - try Untrim, or, more likely, set a finer shading mesh as described here:



It could be an “eye candy” mesh settings thing you can ignore, but without that part of the model, it’s impossible to guess.

Thanks for the fast reply !
My final goal is actually importing the model as a .sat file in to Revit.I tried it with other files and it worked just great but this particular one when imported has distorted geometry at the same place.So its probably not just a “preview” problem when I change render mesh quality to smooth the openings are smaller but still there.And Untrim changes the border all together.Ill will ask the Solidworks if they can troubleshoot the problem also because other geometry/files is fine.

Since the gap changed when you changed the mesh settings, Pascal is right.
Please read the Mesh FAQ link he posted so you understand how render meshes work in Rhino.
I suspect your actual surface is just fine. The thing you’re not understanding is how meshes are fit to NURBS surfaces so they can appear in shaded views.
That’s why I called it “eye candy”.

If you untrim and keep the trimming objects (check the option in the command), you can try and see if retrimming with the curve fixes the problem.

Or you could try the RebuildEdges command.