Surface mesh visual problems after trimming also when converting the surface to mesh

I’m having this weird and unusual render mesh problem. The surface is good and trimmed. In the screenshot, I put Color in the internal back face. The visual representation of the surface is not finishing in the trim edge.

In the trim section, the render mesh is failing. (There is nothing to shrink)

Also, the conversion to mesh fails and evidence the problem.

I need to make a wheel in mm. I’m a bit out of the grid.

GTX 1080Ti latest update.

Any idea on how to fix this problem?

Hello - the surface edges have problems - can you please post the surface and whatever you used to trim?

(You might try RebuildEdges as well. My guess of the moment is that there may be out of tolerance edges)


1 Like

Hello Pascal, thank 4 replay!
I used a curve (out from a filet) that must be close to on surface to trim it.
I will try to project curve on surface.

I open the surface in new Rhino centimetres so that it fits better in the grid, I try RebuildEdges and fix just some of the holes but not all of them.

BadSurface.3dm (2.6 MB)

I used RebuildEdges and as Tolerance 1000000
That fixed the problem THANKS!!!

Hello - look closely here:

in a parallel view (you can zoom closer)

There is an edge that looks like this, up close:

I would try this: with the surface in its untrimmed state, start DivideAlongCreases > SplitAtTangents=Yes, and then select the surface and let it split up into a polysurface, then do the trimming,


1 Like

Did not work “object could not be divided” but now I understand the workflow much better!
I will go to the source of the problem (in this case the curve) and stay in tolerance.

Hello - here is what I get

Command: DivideAlongCreases
One object successfully divided at creases and tangents.

Please make sure to start the command with no selection. (The command needs to be changed to have a ‘Press enter to accept’ style workflow, I have to explain the post select workfow in order to see the option way too often, I’ll get that on the bug list - )

BTW, one way to locate the messy edges is to DupBorder and then turn on the CurvatureGraph for the resulting curve. If you set the scale low enough to see clearly, you can locate the messy areas by the ‘crazy’ graph at those locations.