I hate (my) radius dimensions

Edit:
(This appears to be at least partly a problem with a specific file or configuration here see below…)

They are just too inflexible, I can rarely put them exactly where I want.

In cyan above, what I can get. In red, what I want to have (simulated with a leader).

Basically the radius dimensions are missing a control point. When you turn on points, they have a center “grip”, an arrow “grip” and a text “grip”. But moving the text grip only changes the position and/or length of the arrow section, it cannot change the tail of the leader and bring the text with it.

We really need that 4th control point to make them work more like a leader.

7 Likes

Hi Mitch - got that, thanks.

RH-62533 DimRadius: more control

-Pascal

I think you duplicated mine… https://mcneel.myjetbrains.com/youtrack/issue/RH-62529 :stuck_out_tongue_winking_eye: I maybe should have made the title clearer.

Doubled the pressure. Pascal’s law.

-Pascal

3 Likes

What am I missing here?

It don’t work that way here…

My screen capture program just decided to crash, hang on I’ll get a video up soon…

Hi Mitch - I thought you wanted an extra point on the ‘corner’ … ?

-Pascal

What am I missing here???

I don’t know. I’ll see if I can find something
My video was from 7.4, but I don’t think anything has changed in quite a while

OK, I just tried in a default version of 7.3 - and it seems to work as you showed. So, it may be something with my dimension style that’s causing this ?

@lowell If you try it in the file below, do you see what I see or does it look normal?
DimRadiusForLowell.3dm (316.2 KB)

With your file, it works like in your video.
I don’t see anything yet. I’ll have to spend some time in the debugger I guess

OK, at least I’m not going crazy… :sweat_smile:

Pretty low bar…

1 Like

If it was any higher, I’d trip over it… :stuck_out_tongue_winking_eye:

on mac 7.3.2 something it actually works as shown by Lowell, or am i not getting it? you want to extend the last bar? also what kind of infinity cross have you got there?

I do, still. They should have 4 control points IMO, one at the end of the tail just in front of the dimension number.

Hey @lowell - I think I’ve got something for you… It has to do with the template file used to start my drawing. The file I posted above is based on a custom template - and it possibly came from a V6 custom template (which maybe even came from V5) that was opened and saved in V7 format. As the template file contains a dimension style inherited from V6 (or V5?), that may be the problem.

I any case if I open a new file with that template, I see the problem immediately. If I open a file with no template or with one of the default templates, it behaves as you show in your video.

Here’s the template FWIW…
TemplateMV7.3dm (307.3 KB)

Looks like maybe I need to create a new template from scratch.
Sorry for thinking this was a general problem. As I almost always start with that template, I didn’t know it worked any differently. :flushed:

That’s good info and it sounds like you’re going to be ok now, but there’s still something strange if a different template and/or dimstyle can throw it off like that.
I tried changing a few dimstyle settings that I thought might have some bearing, but didn’t find anything. I’ll still see if I can figure out what causes it. Thanks

found it. on mac only through Rhino.Options.Appearance.ShowCrosshairs

Normally it should also be a checkbox under “Options>Appearance” but I forgot if Mac has that section or not.