I created a custom CPlane, yet the ortho views don't update

  1. I created a custom CPlane set at an angle compared to the World Top one
  2. I saved this CPlane under a custom name
  3. I then did “set CPlane” in the Front, Top and Right views.

Result:

The grid in those views did change, but the “cameras” of them did not.

image

Expected Result:

When I set a CPlane in the Front view, I expect the view to update and always keep the grid perpendicular to the view, not the other way around!

What additional step am I missing?

Also, when I set the CPlane in the Front view, I’m suddenly allowed to orbit that view in 3D space with my 3DConnexion mouse, instead of just panning it in 2D space. This is very bad!

you can type in Plan to set the view.

or

Then save a Named View, this will remember Cplane as well.

Thank you!

Set camera was the step I was missing.

Feels as this should be a macro… whenever you update the CPlane, all ortho views should silently run “set cplane” and then “set camera” to update whatever you did to it…

(That’s how Alias works.) :wink:

Hmm… in Front, I was able to do “set cplane” and then “set camera” and have the navigation back to 2D, but when I do the same in “Right”, the navigation is still 3D, ruining the perpendicular view…

Even weirder, when I create a line in that now updated orthogonal view, the line seems to be locked to the CPlane … I can’t place it anywhere else even with osnap off!

This is bad. :frowning:

When you change the view the Cplane will switch as well. You can also save a NamedCplane and apply to your current view if need be.

What software are you used to drawing in? Autocad?

I’m used to Alias.

So, steps are:

  1. Create CPlane
  2. Save named CPlane
  3. Set CPlane
  4. Set Camera

But again, for me the result is:

The ortho views are then no longer restricted to 2D movement. And any line drawn in those ortho views are restricted to the CPlane.

i don’t believe any view is restricted in movement, you can Shift+Cntl to start to orbit.

Do you have project on? This will constrain the snaps to the Cplane. Rhino will try and guess what plane you are drawing in, so if nothing is in the view i suppose it would always to to the cplane.

There are others around here that are much more experienced in these manipulations. I’ve never used Alias and can’t be of much more help in the translation of workflows.

Hello - I’m not sure how you’re doing it, but to ‘set camera’, use the Plan command. That will set a plan ortho view that should not behave any differently from the standard ones as far as navigation goes.

-Pascal

I think you have to choose UPlane mode so the orthe views will align with the new Cplane you choose

1 Like

When I press that, I get a lot of spam in the command line, and then nothing happens. The ortho views remain unchanged.

Thank you, that worked for the Front view, but if I do the same for Top and Right, they become the exact same view. And if I try to change, say the Top view to Cplane Top via the menu after plan, I get 3D rotation again.

they will change the next time you change the cplane

1 Like

YES!

That was the missing puzzle piece. Thank you so much!

the good thing is that once set to UPlane. will always works like that. it should come by default.

1 Like

ohh, that could be handy, although i wouldn’t want it on by default, due to insert origins etc.

Yes, absolutely. Just like the planar option. Should be default.