I can’t switch from CPU to GPU

Hi, I am trying to render something in Raytraced view and Ive noticed the app uses CPU Intel Iris instead of GPU Nvidia GeForce so it is taking forever. I cant even change it under options-cycles. What do I do?
WhatsApp Image 2024-03-20 at 16.37.05_50147039
WhatsApp Image 2024-03-20 at 16.38.12_572a27fe

According your screenshot you don’t have any supported Nvidia GPU. You need at least a Maxwell-based GPU.

Please run the Rhino command _SystemInfo and post the result in a reply. That should tell us enough about whether it should show or not.

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09491, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: tion, build 2020-12-08
License details: Stand-Alone

Windows 10.0.22631 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) Iris(R) Xe Graphics (Intel) Memory: 1GB, Driver date: 7-11-2023 (M-D-Y).
> Integrated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce RTX 3050 Laptop GPU (NVidia) Memory: 4GB, Driver date: 11-9-2023 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 546.17
> Integrated acclerated graphics device with 4 adapter port(s)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-9-2023
Driver Version: 31.0.15.4617
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.1.20343.9491
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

You should

Make sure you updated to a non-cracked installation of the latest Rhino 7 service release, yours is more than 30 service releases behind. Rhino 7.1 didn’t support yet RTX 3050, but latest 7.35 and 7.36 do.

Unofficial Rhino versions like this are bound to run into problems. You can’t be certain that any cracks applied have not altered the working of Rhino.

You probably need to buy a valid licens too. tion is not a valid license type.

Ensure you have all Windows 10 updates installed, you’re behind on this quite a bit too.

Update your GPU drivers to the latest available for your model.

3 Likes