How to use gumball with wacom intuos tablet / pen in Rhino 6? SOLVED

unhandled
wacom
#1

SOLVED with this post: How to set a wacom tablet in order to pan, rotate and zoom in/out

UPDATED QUESTIONS:

  1. What settings do I need to change in the Wacom tablet properties (or elsewhere in my platform) in order to use the pen in combination with shift/ctrl keys for quick actions like dynamic zooming or panning?

  2. Why does the toolbar work when I click it, but the menu requires me to click the pen button “click”? My pen tip is set to right click. When I change it to just “click”, then it no longer selects items.

  3. Sometimes the “click” button on the pen initiates a pan, or orbit when in perspective view…and other times it doesn’t. It’s totally random. How to fix this?

Ive been using small wacom intuos tablet for photoshop and day to day computer navigation with joy for the last several months. But whenever I try to use it with rhino 6, I get frustrated b/c I can’t seem to figure out the settings to drag items with gumbal, or even just select things without using the side buttons. Ideally, I’d use the keyboard for most imputs and the pen to select and modify (move, scale, etc, via gumball). Right now I don’t mind that the pen pans when I click on the tablet and move, but if I click on an item, nothing happens despite the pens tip set to “click”.

If I use the “right click” button set on my pen, then it does select the item, but then I can’t figure out how to scale/move using the gumball?

Or, right now as Im trying to figure it out, I can’t zoom with the zoom command. With a mouse I would hit “z” on keyboard, space bar to initiate, then select the zoom window. I do this fast and at this point intuitively. But the pen won’t zoom. It just pans the screen with I try to create the zoom window. Unless I click the pen button… but I was hoping to not rely on the pen button. Any suggestions?

And right click on the pen doesn’t work on the tab menu (to, for example, duplicate a layout)?

Does anyone have any success using the wacom and what are your settings if I may ask? What do you set your pen button and tip settings to? What do you set the tablet keys to (I have four)?

Help! I love the pen and really want to make it work for me.

Thank you :pray::heart_eyes:

#2

Hi Peter,
I couldn’t live without my wacom- perfect for working in Rhino (5, but the gumball should be the same?)
But I prefer this button setup:
PenButtons
Double-click has no function in Rhino as far as I know (?) so this setup also works better for navigating windows folders - single-click (tap with pen tip) to select an item or press a button/check-box etc, double-click (hover pen-tip over folder and press upper pen button) to open, etc.

For navigation in Rhino viewport use the keyboard-pen combos:
Hold down Shift + hold down Right-Click and drag in window to Pan
Hold down Ctrl + hold down Right-Click and drag up/down in window to Zoom
Hold down Right-Click and drag in window to Orbit

To use Gumball make a selection just tap item with pen-tip (Shift-Tap to add to selection, Ctrl-Tap to deselect) and then use the gumball controls- Pen Down and drag, Pen Up to complete.

Right-Click is equivalent to the Return key so use the pen to repeat last command., etc as well…

To me this is now second-nature, and saves me hundreds of mouse clicks an hour :grin:

Also, get yourself a 3dconnexion SpaceMouse for viewport navigation: you’ll never regret it!

#3

Thanks Cairn! This looks promising! I’ll give it a shot as soon as I have a moment!

#4

HI again. I tried your settings and your suggested moves… none of them worked for me. hold ctrl + hold right click drag does nothing… neither do the other moves. You must have these settings set somewhere deeper, maybe within rhino?

#5

Odd. Did you change the pen buttons first?
(I remember sometimes having difficulty getting bthe wacom settings to stick reliably…)

#6

Ah, also to be accurate:

These two work only in the perspective viewport:
Hold down Shift + hold down Right-Click and drag in window to Pan
Hold down Right-Click and drag in window to Orbit
In Orthogonal views:
Hold down Right-Click and drag in window to Pan.

#7

I did change them to your settings but doesn’t work.

#8

Hmm, Rhino 6 maybe handles it differently…

#9

Possibly… or there are more settings within wacom / rhino that Im not seeing…"?

#10

I’ll have a look when I upgrade…:wink:

#11

Thanks. Let me know. By the way, what are your rhino mouse settings in preferences? Maybe that has something to do with it?

#12

by the way, I solved the issue with this post: How to set a wacom tablet in order to pan, rotate and zoom in/out