How to show curves and points in rendered and/or Arctic mode


#1

As the title says, how do I show Grasshopper generated points and curves in renderd and/or arctic mode?

I get them to show in Shaded:
image

But in arctic I only get the surface to show as I have a custom preview material assigned to it:

But I would really like to show them both as if the curves were baked.


No grasshopper preview in rendered mode (viewport style)
Grasshopper not previewing
Grasshopper Display Messed-up
Grasshopper Display Messed-up
#2

This doesn’t help?

image


#3

No, I am talking about grasshopper generated data.
(And as you can see in the bottom image I allready show curves and points in the arctic mode)
Edit: I updated the original post so it is more apparent.


#4

Ah, sorry, didn’t see the topic heading…


#5

No worries, and as always thanks for your time and willingness to help Mitch!


(David Rutten) #6

Arctic is a kind of ‘rendered’ viewport, and as such only shows Grasshopper geometry that is present in a Custom Preview component. And only meshes at that, so no points and curves.


#7

Then we need a CustomPreview for curves as well.
And please make CustomPreview display mode sensitive, because not being able to see an object in Shaded if it has a CustomPreview setting makes Grasshopper slower to use.


(David Rutten) #8

You’ll need to take that up @andy, as he has to make the custom render mesh pipeline flexible enough to support curves and points with styles.

I don’t understand. Custom Preview will either draw the stuff inside of it in a viewport if that viewport is not of the rendered type, or it will pass on it’s meshes and materials to Rhino and whatever Render engine is running so they can be included in the default display.


#9

Oh… that made me build a new dummy and for some reason that works as you describe in both shaded and rendered:

So now I have to bugtrack the other definition and figure out why it doesn’t draw as expected. I’ll let you know.