How to reset the lights setting


#1

hi. i’ve been playing around with my light settings and now if i turn off - or even delete - the layer where i’ve put my light settings, my model becomes really dark and the shadow deep blue when in render preview mode. how can i solve this problem? by the way, for some reason (probably an unvoluntary shortcut) the orientation of my space keeps on rotating, so the virtual ‘floor’ becomes vertical. if anyone knows how to solve this aswell that would be great. thanx in advance.


(Brian James) #2

Can you post the model or a portion of it that shows the issue? Also, what render plugin if any are you using?

I’m not sure what the issue is but my hunches are that the active renderer isn’t fully supported in the Rendered display mode or that you may have a custom display mode set up or be using a light type that doesn’t produce shadows in OpenGL.

If the Cplane changes, you may be switching it and not realizing by way of a macro or the Cplane panel. Try and notice exactly when this happens next time and let me know what you did right before the Cplane changed.


#3

i have posted a portion of the model showing the issue.


(Brian James) #4

I don’t see an attachment… also, what Renderer if any are you using?


#5

vray - the lighting come from vray. i don’t what to tell you about the attachment. i see it.


(Brian James) #6

That’s odd, I asked another tech if they saw the attachment here too but no luck. In any case, you can always email tech support with a file by using www.rhino3d.com/upload and entering a description of what you’re asking about.

My suspicion is that the material applied may be a Vray metal or some such type that the display isn’t fully supporting and that’s why the default shadows and the diffuse color look the way you’ve shown. Try changing the material to a basic Rhino material as a test to see if that changes anything. I’d also suggest contacting the Vray developers to see if they have any suggestions… if you haven’t already.


#7

i just tried to contact through the link you posted but i got this:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

AccessDenied

Invalid according to Policy: Policy Condition failed: [“eq”, “$acl”, “private”]

3CE7A3E72D2680A2

mcXWktFMKLaNyku6raX9x9857YZmTdivwnn5PtLHioAH/GXEtN9TLlMQHOY+jIQMMqFWenb/Xdw=


(Brian James) #8

I’m not sure why the upload link isn’t working for you, just tested it here and it’s fine. Maybe try this one… http://www.rhino3d.com/upload


#9

i did it again with the new link - and with a new screenshot saved as a jpeg and i still get a message error.

This XML file does not appear to have any style information associated with it. The document tree is shown below.

AccessDenied

Invalid according to Policy: Policy Condition failed: [“eq”, “$acl”, “private”]

BDB169E7E75B6B12

0qHANKI5mi9puw6CrI/4pBmHa5WiPrBZcjvkQ2R57MPAq/nWxWfBYyxJLYiZL2cZevNjyNNQy8k=


(Brian James) #10

Sorry, you’re having repeated problems trying to upload a file. I haven’t heard of anyone else not being able to use the upload page so I wonder if the issue on your end could be due to a network firewall or system setting. If you can, and have an IT department, check with them. Otherwise, I’d suggest trying an alternate machine and internet connection as a test.

I’m still thinking you’ll need to run this be the Vray tech support directly though. The Vray materials and lighting you’re using may not be supported in the Rendered display mode. They may have an update to suggest trying or can say what the plugin can and can’t display in Rhino’s Rendered mode.


#11

can you see it now?


(Wim Dekeyser) #12

We can see the picture, yes. The question, however, is if you could provide the 3dm file. You can attach that the same way as you did with the picture.


#13

it’s a file i’m working on for work - a screenshot jpeg is the max info i can publish online (confidential policy).


(Brian James) #14

I understand. I will need to see another model then that exhibits the same issue to try and help more. Please contact Vray support as well with the file you can share. I’m fairly confident that the issue is plugin specific given what I know so far.


#15

Dear SoMa
did you try to copy /paste your geometry - and only the geometry - into a new file?
did you try to save the file “save small” and reopen it ? - this will force rhino to rebuild all render-meshes.
what happens if you draw a new object - like a simple cube / _box ?
you might want to match properties of an intact /correct object with matchproperties…
http://docs.mcneel.com/rhino/5/help/en-us/commands/matchproperties.htm
good luck
best tom