How to get glass to show up in rendered view?

This highlight below is the only evidence that there’s a glass door in this opening:

bild

In most other camera angles, the glass is 100% invisible.

And this is despite me setting a grey tint on it (I don’t want frosted, but even if I do tweak that, all that happens is that the highlight fades away).

Hello - there is not a good way that I know of. I recommend making two glass materials, one tinted, maybe with low gloss and not quite transparent. Use the tinted one for rendered display, the clear one for rendering. It is relatively easy to select all objects using a particular material from the material panel context menu for the material and assigning a different material is similar.

-Pascal

1 Like

Thanks, but as I said, the most I can do is affect the highlight, not the actual glass itself.

Also, I think there’s something wrong with my rendered view, as this is what happens when I choose a “metal” material:

It doesn’t even receive a shadow. The entire object just fades between black and white.

Hello - I’m not sure I follow completely but here is a tinted less transparent glasslike material and a default glass material:

If it is reflection that is lacking, then (also judging from your metal image, but I can’t really see what is going on there) you may want to ‘RestoreDefaults’ in the Rendering panel.

-Pascal

1 Like

Would adding some sort of environment to the scene give the glass material something to reflect, thereby making it look more like glass perhaps?

1 Like

Yeah, that is why I suggested restoring the defaults in the Rendering panel - maybe that is all there is to it.
-Pascal

1 Like

@John_Brock @pascal

Thanks, resetting the render settings made the metal look like metal, but it also made the entire viewport very noisy (though I can live with that).

The glass, though… it shows up very dark grey in raytraced mode, but even in this noisy render, it’s extremely difficult to see.

(In the above image, believe it or not, there’s an entire curved glass door, in addition to that metal handle.)

Also, follow up question: I’m not allowed to assign a material to a block? I select in the menu, but nothing happens.

What happens if you put some stuff on the other side of the door (I mean so as not to have just white space) ? Is the glass material a Rhino default one?
To assign materials to a block, BlockEdit and assign to the objects in the block or ByParent so it will use the layer material.

-Pascal

If I put things behind, it’s still pretty much invisible save for the highlight. If I color it bright green, I can see a faint, faint shade of extremely light green where the door is.

bild

bild

Solved it. Switched to plastic instead, since it had a transparency slider.

bild

Sorry, but the default glass material is imo unusable.

That is weird - these use the glass material:

Can you please post or PM me a file with that door?

-Pascal

PM sent. But it looks like you are using raytraced view, while I’m talking about rendered view.

The most important thing for glass is having an en environment to reflect(or pretend to reflect in the case of the OpenGL view.) What are you using for that?

I tried several different things. The solution was not to use the built-in glass material, and instead use a plastic or custom material.